Til the Cows Come Home(求最短路径)

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90
题目大意:一个人想从自己所在的点(N)以最快的方式走到1点,每组案例给出T个关系,(1 2 5)即代表1点和2点距离是5。一共有T组这样的关系。下面让我们求出从N点到1点的最短距离。
 
大致想法:用Dijkstra算法,说这个你也并不认识他。我觉得这种算法就是在求最小生成树的基础上稍稍改动了一下下。就是再更新的时候有点区别。求最小生成树的时候是拿新的边(其它点到新找出的节点的距离,不包括已经确定的节点)与之前节点的边进行比较。而最短路径是拿新边加上之前的构成最小生成树的所有边与之前的边的和比较,保留较小的到达指定地点即可跳出循环,输出结果。 
 
代码如下:(重点的地方有解释哟)
#include<cstdio>
int map[10000][10000],d[10000],n,maxx=100000;
void dijkstra(int v)
{
       int i,j;
       bool s[10000]={false};
       for(i=1;i<=n;i++)
                d[i]=map[v][i];
        d[v]=0;s[v]=true;
        for(i=1;i<n;i++)
       {
          int temp=maxx;
          int u=v;
          for(j=1;j<=n;j++)
           if((!s[j])&&(d[j]<temp))//找出最小的那条边
               {
                    u=j;
                    temp=d[j];
                }
           s[u]=true;
           for(j=1;j<=n;j++)
            if((!s[j])&&(map[u][j]<maxx)&&(d[u]+map[u][j])<d[j])//没访问过那个节点并且找到的最新的路径比原先的小就要进行更新
             d[j]=d[u]+map[u][j];
        }
}
int main()
{
       int t,a,b,c;
       scanf("%d%d",&t,&n);
        for(int i=1;i<=n;i++)
                for(int j=1;j<=n;j++)
                        map[i][j]=maxx;
         while(t--)
          {
                scanf("%d%d%d",&a,&b,&c);
                if(map[a][b]&&c>=map[a][b])continue;//为避免重边,就是两个点之间可能不止一条边,我们应当取最小的那条并保存
                map[a][b]=map[b][a]=c;
           }
        dijkstra(n);
        printf("%d\n",d[1]);
        return 0;
}

转载于:https://www.cnblogs.com/441179572qqcom/p/5719542.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值