POJ 2154 Color(组合数学-波利亚计数,数论-欧拉函数,整数快速幂)

Color
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7693 Accepted: 2522

Description

Beads of N colors are connected together into a circular necklace of N beads (N<=1000000000). Your job is to calculate how many different kinds of the necklace can be produced. You should know that the necklace might not use up all the N colors, and the repetitions that are produced by rotation around the center of the circular necklace are all neglected. 

You only need to output the answer module a given number P. 

Input

The first line of the input is an integer X (X <= 3500) representing the number of test cases. The following X lines each contains two numbers N and P (1 <= N <= 1000000000, 1 <= P <= 30000), representing a test case.

Output

For each test case, output one line containing the answer.

Sample Input

5
1 30000
2 30000
3 30000
4 30000
5 30000

Sample Output

1
3
11
70
629

Source

POJ Monthly,Lou Tiancheng

题目大意:

T组测试数据,每组一个n表示1个项链有n个颜色可以涂在n个钻石上,通过旋转相同的算一种方案,问你方案数是多少?


解题思路:

很裸的波利亚计数,转化为的公式就是 ans=sum{ n^( gcd(1,n)-1  ) ,n^( gcd(2,n)-1  ),n^( gcd(3,n)-1  ) .....n^( gcd(n,n)-1  )     },因为这个n比较大10^9,所以暴力超时。

因此枚举 gcd(k,n)=l 的有多少个,也就是 k=l*x ,n=l*y,也就是gcd(x,y)=1,也就是找到 1~y与y互质的数有多少个,答案:欧拉函数


解题代码:

#include <iostream>
#include <cstdio>
using namespace std;

typedef long long ll;
int n,p;

inline ll getPhi(int x){
    ll ans=x;
    for(int i=2;i*i<=x;i++){
        if(x%i==0){
            ans=ans/i*(i-1);
            while(x%i==0) x/=i;
        }
    }
    if(x>1) ans=ans/x*(x-1);
    return ans;
}

inline ll pow_mod(ll a,ll b){
    ll sum=1;
    while(b>0){
        if(b&1) sum=(sum*a)%p;
        a=(a*a)%p;
        b/=2;
    }
    return sum%p;
}

int main(){
    int t;
    scanf("%d",&t);
    while(t-- >0){
        scanf("%d%d",&n,&p);
        ll ans=0;
        for(int i=1;i*i<=n;i++){
            if(n%i==0){
                if(i*i==n) ans=(ans+(getPhi(i)*pow_mod(n,i-1))%p)%p;
                else{
                    ans=(ans+(getPhi(n/i)*pow_mod(n,i-1))%p)%p;
                    ans=(ans+(getPhi(i)*pow_mod(n,n/i-1))%p)%p;
                }
            }
        }
        printf("%lld\n",ans%p);
    }
    return 0;
}





转载于:https://www.cnblogs.com/toyking/p/3893183.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值