POJ 1815 Friendship (Dinic)

                    Friendship
Time Limit: 2000MS Memory Limit: 20000K
Total Submissions: 11429 Accepted: 3173

Description

In modern society, each person has his own friends. Since all the people are very busy, they communicate with each other only by phone. You can assume that people A can keep in touch with people B, only if 
1. A knows B's phone number, or 
2. A knows people C's phone number and C can keep in touch with B. 
It's assured that if people A knows people B's number, B will also know A's number. 

Sometimes, someone may meet something bad which makes him lose touch with all the others. For example, he may lose his phone number book and change his phone number at the same time. 

In this problem, you will know the relations between every two among N people. To make it easy, we number these N people by 1,2,...,N. Given two special people with the number S and T, when some people meet bad things, S may lose touch with T. Your job is to compute the minimal number of people that can make this situation happen. It is supposed that bad thing will never happen on S or T. 

Input

The first line of the input contains three integers N (2<=N<=200), S and T ( 1 <= S, T <= N , and S is not equal to T).Each of the following N lines contains N integers. If i knows j's number, then the j-th number in the (i+1)-th line will be 1, otherwise the number will be 0. 

You can assume that the number of 1s will not exceed 5000 in the input. 

Output

If there is no way to make A lose touch with B, print "NO ANSWER!" in a single line. Otherwise, the first line contains a single number t, which is the minimal number you have got, and if t is not zero, the second line is needed, which contains t integers in ascending order that indicate the number of people who meet bad things. The integers are separated by a single space.

If there is more than one solution, we give every solution a score, and output the solution with the minimal score. We can compute the score of a solution in the following way: assume a solution is A1, A2, ..., At (1 <= A1 < A2 <...< At <=N ), the score will be (A1-1)*N^t+(A2-1)*N^(t-1)+...+(At-1)*N. The input will assure that there won't be two solutions with the minimal score. 

Sample Input

3 1 3
1 1 0
1 1 1
0 1 1

Sample Output

1
2
思路:
感谢llw大佬的神奇优化!!!!
耗时两天,终于AC了,总算是证明了自己的算法没有错误。
网上遍地都是拆点的题解,奈何我实在是太弱了,弱到无法想象的地步,实在是看不懂拆点应该要怎么拆,所以我被逼无奈选择了暴力。
那就是,限制一次dfs只能跑出容量为1的流,并将这条流上的所有点标记为不可用,直到一次Dinic结束。
以此取代拆点的操作,是完全可行的,其他的操作都大体相同
终于终于,体会到了AC的快乐,看着题解写出来的题,渐渐地成为了我自闭的根源
代码
邻接矩阵
#include<iostream>
#include<cstring>
#include<queue>
#include<cstdio>
using namespace std;
int mp[300][300];
int n,s,t;
const int inf = 2100000000;
int vis[400],num[400];
bool book[400];

struct edge
{
    int u,v,next,w;
}e[400010];
int Head[400010],cur;
int ans[400010];

void add(int x,int y)
{   e[cur].u=x;
    e[cur].v=y;
    e[cur].next=Head[x];
    e[cur].w=1;
    Head[x]=cur;
    cur++;
    e[cur].u=y;
    e[cur].v=x;
    e[cur].next=Head[y];
    e[cur].w=0;
    Head[y]=cur;
    cur++;
}

bool bfs()
{
    memset(vis,0,sizeof(vis));
    for(int i=1;i<=n;i++){
        num[i]=Head[i];
    }
    vis[s]=1;
    queue<int>q;
    q.push(s);
    int r=0;
    while(!q.empty()){
        int u=q.front();
        q.pop();
        int k=Head[u];
        while(k!=-1){
            if(!book[e[k].v]&&!vis[e[k].v]&&e[k].w){
                vis[e[k].v]=vis[u]+1;
                q.push(e[k].v);
            }
            k=e[k].next;
        }
    }
    return vis[t];
}

int dfs(int u)
{
    if(u==t){return 1;}

    int &k=num[u];
    while(k!=-1){
        if(!book[e[k].v]&&vis[e[k].v]==vis[u]+1&&e[k].w){
            int d=dfs(e[k].v);
            e[k].w-=d;
            e[k^1].w+=d;
            if(d>0){book[u]=true;return 1;}
        }
        k=e[k].next;
    }
    return 0;
}

void build()
{
    cur=0;
    memset(Head,-1,sizeof(Head));
    for(int i=1;i<=n;i++){
        for(int j=1;j<=n;j++){
           if(mp[i][j]) add(i,j);
        }
    }
}

int Dinic(int y)
{
    memset(book,0,sizeof(book));
    book[y]=1;
    int ans=0;
    while(bfs()){
        int f;
        while((f=dfs(s))>0){//llw大佬太强了orz orz orz
            ans+=f;
        }
    }
    return ans;
}

inline void rebuild(int tt)
{
    for(int i=0;i<=cur;i+=2){
        if(e[i].v==tt||e[i].u==tt){e[i].w=e[i^1].w=0;}
        else if(e[i^1].w!=0){
            e[i].w=1;
            e[i^1].w=0;
        }
    }


}
int main()
{
    scanf("%d%d%d",&n,&s,&t);
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                scanf("%d",&mp[i][j]);
            }
        }
        if(mp[s][t]==1){printf("NO ANSWER!\n");return 0;}
        build();
        int maxx=Dinic(0);
        rebuild(0);
        int num=0;
        for(int i=1;i<=n;i++){
            if(i==s||i==t){continue;}
            int y=Dinic(i);
            if(y<maxx){
                ans[++num]=i;
                maxx=y;
                if(maxx==0){break;}
                rebuild(i);
            }
            else rebuild(0);
        }
        if(num==0){printf("0\n");return 0;}
        printf("%d\n",num);
        for(int i=1;i<=num;i++){
            if(i!=1){printf(" ");}
            printf("%d",ans[i]);
        }
        printf("\n");
}

  

 

转载于:https://www.cnblogs.com/ZGQblogs/p/9420172.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值