hdu-4123 Bob’s Race(树形dp+RMQ)

题目链接:

Bob’s Race

Time Limit: 5000/2000 MS (Java/Others)   

 Memory Limit: 32768/32768 K (Java/Others)


Problem Description
Bob wants to hold a race to encourage people to do sports. He has got trouble in choosing the route. There are N houses and N - 1 roads in his village. Each road connects two houses, and all houses are connected together. To make the race more interesting, he requires that every participant must start from a different house and run AS FAR AS POSSIBLE without passing a road more than once. The distance difference between the one who runs the longest distance and the one who runs the shortest distance is called “race difference” by Bob. Bob does not want the “race difference”to be more than Q. The houses are numbered from 1 to N. Bob wants that the No. of all starting house must be consecutive. He is now asking you for help. He wants to know the maximum number of starting houses he can choose, by other words, the maximum number of people who can take part in his race.
 

 

Input
 
There are several test cases.
The first line of each test case contains two integers N and M. N is the number of houses, M is the number of queries.
The following N-1 lines, each contains three integers, x, y and z, indicating that there is a road of length z connecting house x and house y.
The following M lines are the queries. Each line contains an integer Q, asking that at most how many people can take part in Bob’s race according to the above mentioned rules and under the condition that the“race difference”is no more than Q. 

The input ends with N = 0 and M = 0.

(N<=50000 M<=500 1<=x,y<=N 0<=z<=5000 Q<=10000000)
 

 

Output
 
For each test case, you should output the answer in a line for each query.
 

 

Sample Input
 
5 5
1 2 3
2 3 4
4 5 3
3 4 2
1
2
3
4
5
0 0
 

 

Sample Output
1
3
3
3
5
 
题意:
 
给一棵树,从每个点出发,这点的权值为这点能到的最远的距离;有m个询问,问连续的ans个点的权值<=q,(ans为要求的最大值);
 
思路:
 
先3遍的bfs找出每个点的权值,然后用ST算法求出RMQ;然后用尺取法来找出答案,也可以用单调队列搞定;
 
AC代码:
 
/*4123    717MS    13772K    3360 B    G++    2014300227*/
#include <bits/stdc++.h>
#include <cmath>
using namespace std;
const int N=50004;
int n,m,u,v,w,cnt,head[N];
struct Edge
{
    int to,next,val;
};
Edge edge[2*N];
void add_edge(int s,int e,int va)
{
    edge[cnt].to=e;
    edge[cnt].next=head[s];
    edge[cnt].val=va;
    head[s]=cnt++;
}
int dis1[N],dis2[N],dis[N],pin[N][25],pax[N][25],vis[N],f[N];
queue<int>qu;
int bfs()
{
    memset(vis,0,sizeof(vis));
    //memset(dis1,0,sizeof(dis1));
    qu.push(1);
    vis[1]=1;
    dis1[1]=0;
    while(!qu.empty())
    {
        int fr=qu.front();
        qu.pop();
        for(int i=head[fr];i!=-1;i=edge[i].next)
        {
            int fx=edge[i].to;
            if(!vis[fx])
            {
                dis1[fx]=dis1[fr]+edge[i].val;
                vis[fx]=1;
                qu.push(fx);
            }
        }
    }
}
int bfs1()
{
    int ans=1;
    for(int i=1;i<=n;i++)
    {
        if(dis1[i]>=dis1[ans])
        {
            ans=i;
        }
    }
    //memset(dis1,0,sizeof(dis1));
    memset(vis,0,sizeof(vis));
    qu.push(ans);
    vis[ans]=1;
    dis1[ans]=0;
    while(!qu.empty())
    {
        int fr=qu.front();
        qu.pop();
        for(int i=head[fr];i!=-1;i=edge[i].next)
        {
            int fx=edge[i].to;
            if(!vis[fx])
            {
                dis1[fx]=dis1[fr]+edge[i].val;
                vis[fx]=1;
                qu.push(fx);
            }
        }
    }
}
int bfs2()
{
    //memset(dis2,0,sizeof(dis2));
    memset(vis,0,sizeof(vis));
    int ans=1;
    for(int i=1;i<=n;i++)
    {
        if(dis1[i]>=dis1[ans])
        {
            ans=i;
        }
    }
    qu.push(ans);
    vis[ans]=1;
    dis2[ans]=0;
    while(!qu.empty())
    {
        int fr=qu.front();
        qu.pop();
        for(int i=head[fr];i!=-1;i=edge[i].next)
        {
            int fx=edge[i].to;
            if(!vis[fx])
            {
                vis[fx]=1;
                dis2[fx]=dis2[fr]+edge[i].val;
                qu.push(fx);
            }
        }
    }
}
int rmq()
{

    for(int i=1;i<=n;i++)
    {
        f[i]=(int)(log(i*1.0)/log(2.0));
        dis[i]=max(dis1[i],dis2[i]);
       pax[i][0]=pin[i][0]=dis[i];

    }
    for(int j=1;j<=f[n];j++)
    {
        for(int i=1;i+(1<<(j-1))<=n+1;i++)
        {
            pin[i][j]=min(pin[i][j-1],pin[i+(1<<(j-1))][j-1]);
            pax[i][j]=max(pax[i][j-1],pax[i+(1<<(j-1))][j-1]);
        }
    }
}
int get_ans(int x)
{
    int l=1,r=1,ans=0,mmax,mmin;
    while(r<=n)
    {
        int temp=f[r-l+1];
        mmax=max(pax[l][temp],pax[r-(1<<temp)+1][temp]);
        mmin=min(pin[l][temp],pin[r-(1<<temp)+1][temp]);
        if(mmax-mmin<=x)ans=max(ans,r-l+1),r++;
        else l++;
    }
    return ans;
}
int main()
{
    while(1)
    {
        scanf("%d%d",&n,&m);
        if(n==0&&m==0)break;
        cnt=0;
        memset(head,-1,sizeof(head));
        for(int i=1;i<n;i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            add_edge(u,v,w);
            add_edge(v,u,w);
        }
        bfs();
        bfs1();
        bfs2();
        rmq();
        while(m--)
        {
            int q;
            scanf("%d",&q);
            printf("%d\n",get_ans(q));
        }

    }
}

 

转载于:https://www.cnblogs.com/zhangchengc919/p/5392059.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Go语言(也称为Golang)是由Google开发的一种静态强类型、编译型的编程语言。它旨在成为一门简单、高效、安全和并发的编程语言,特别适用于构建高性能的服务器和分布式系统。以下是Go语言的一些主要特点和优势: 简洁性:Go语言的语法简单直观,易于学习和使用。它避免了复杂的语法特性,如继承、重载等,转而采用组合和接口来实现代码的复用和扩展。 高性能:Go语言具有出色的性能,可以媲美C和C++。它使用静态类型系统和编译型语言的优势,能够生成高效的机器码。 并发性:Go语言内置了对并发的支持,通过轻量级的goroutine和channel机制,可以轻松实现并发编程。这使得Go语言在构建高性能的服务器和分布式系统时具有天然的优势。 安全性:Go语言具有强大的类型系统和内存管理机制,能够减少运行时错误和内存泄漏等问题。它还支持编译时检查,可以在编译阶段就发现潜在的问题。 标准库:Go语言的标准库非常丰富,包含了大量的实用功能和工具,如网络编程、文件操作、加密解密等。这使得开发者可以更加专注于业务逻辑的实现,而无需花费太多时间在底层功能的实现上。 跨平台:Go语言支持多种操作系统和平台,包括Windows、Linux、macOS等。它使用统一的构建系统(如Go Modules),可以轻松地跨平台编译和运行代码。 开源和社区支持:Go语言是开源的,具有庞大的社区支持和丰富的资源。开发者可以通过社区获取帮助、分享经验和学习资料。 总之,Go语言是一种简单、高效、安全、并发的编程语言,特别适用于构建高性能的服务器和分布式系统。如果你正在寻找一种易于学习和使用的编程语言,并且需要处理大量的并发请求和数据,那么Go语言可能是一个不错的选择。
Go语言(也称为Golang)是由Google开发的一种静态强类型、编译型的编程语言。它旨在成为一门简单、高效、安全和并发的编程语言,特别适用于构建高性能的服务器和分布式系统。以下是Go语言的一些主要特点和优势: 简洁性:Go语言的语法简单直观,易于学习和使用。它避免了复杂的语法特性,如继承、重载等,转而采用组合和接口来实现代码的复用和扩展。 高性能:Go语言具有出色的性能,可以媲美C和C++。它使用静态类型系统和编译型语言的优势,能够生成高效的机器码。 并发性:Go语言内置了对并发的支持,通过轻量级的goroutine和channel机制,可以轻松实现并发编程。这使得Go语言在构建高性能的服务器和分布式系统时具有天然的优势。 安全性:Go语言具有强大的类型系统和内存管理机制,能够减少运行时错误和内存泄漏等问题。它还支持编译时检查,可以在编译阶段就发现潜在的问题。 标准库:Go语言的标准库非常丰富,包含了大量的实用功能和工具,如网络编程、文件操作、加密解密等。这使得开发者可以更加专注于业务逻辑的实现,而无需花费太多时间在底层功能的实现上。 跨平台:Go语言支持多种操作系统和平台,包括Windows、Linux、macOS等。它使用统一的构建系统(如Go Modules),可以轻松地跨平台编译和运行代码。 开源和社区支持:Go语言是开源的,具有庞大的社区支持和丰富的资源。开发者可以通过社区获取帮助、分享经验和学习资料。 总之,Go语言是一种简单、高效、安全、并发的编程语言,特别适用于构建高性能的服务器和分布式系统。如果你正在寻找一种易于学习和使用的编程语言,并且需要处理大量的并发请求和数据,那么Go语言可能是一个不错的选择。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值