18002 Z-Scan 模拟题

18002 Z-Scan

时间限制:1000MS  内存限制:65535K
提交次数:0 通过次数:0

题型: 编程题   语言: 不限定

 

Description

Z-Scan is a method to scan data in a square matrix(矩阵). Fig.1 shows Z-Scan. Here, the number stands for 
the scan sequence number of the element.
Our question is very simple. Given the size (n * n) of the square matrix and the row and column of the matrix element, 
could you tell me the scan sequence number of the element?




输入格式

The first line is an integer N, the number of cases, 1<=N<=10
N lines follow. Each line contains 3 integers(n r c), The "n" stands for a square matrix in size of n * n.
The "r" is the row of the element. The "c" is the column of the element.  1 <= r, c <= n <= 100 



输出格式

For each case, output the scan sequence number of the element.



 

输入样例

3
5 1 2
5 4 5
99 99 99



 

输出样例

2
23
9801



 

来源

 Mr. Chen 

 

作者

 admin

 

模拟题打表,模拟的时候用dfs模拟

注意到只有两种方向,

一种是x + 1, y - 1

一种是x - 1, y + 1

其他那些向下和向左,是作为边界来处理的。

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
#define IOS ios::sync_with_stdio(false)
using namespace std;
#define inf (0x3f3f3f3f)
typedef long long int LL;

#include <iostream>
#include <sstream>
#include <vector>
#include <set>
#include <map>
#include <queue>
#include <string>
int n, r, c;
const int maxn = 1e2 + 20;
int a[maxn][maxn];
int tonext[2][2] = {{1, -1}, {-1, 1}};
void dfs(int num, int x, int y, int now) {
    a[x][y] = num;
    if (x == n && y == n) return;
    if (now == 0) { //减y的
        if (y == 1 && x != n) {
            dfs(num + 1, x + 1, y, !now);
        } else if (x == n) {
            dfs(num + 1, x, y + 1, !now);
        } else {
            dfs(num + 1, x + tonext[now][0], y + tonext[now][1], now);
        }
    } else { //减x的
        if (x == 1 && y != n) {
            dfs(num + 1, x, y + 1, !now);
        } else if (y == n) {
            dfs(num + 1, x + 1, y, !now);
        } else {
            dfs(num + 1, x + tonext[now][0], y + tonext[now][1], now);
        }
    }
}
void work() {
    scanf("%d%d%d", &n, &r, &c);
    a[1][1] = 1;
    dfs(2, 1, 2, 0);
//    for (int i = 1; i <= n; ++i) {
//        for (int j = 1; j <= n; ++j) {
//            printf("%d ", a[i][j]);
//        }
//        printf("\n");
//    }
    printf("%d\n", a[r][c]);
}

int main() {
#ifdef local
    freopen("data.txt","r",stdin);
#endif
    int t;
    scanf("%d", &t);
    while (t--) work();
    return 0;
}

 

转载于:https://www.cnblogs.com/liuweimingcprogram/p/6053852.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值