多校3- RGCDQ 分类: 比赛 HDU ...

RGCDQ
Time Limit:3000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit

Status

Practice

HDU 5317
Appoint description:
Description
Mr. Hdu is interested in Greatest Common Divisor (GCD). He wants to find more and more interesting things about GCD. Today He comes up with Range Greatest Common Divisor Query (RGCDQ). What’s RGCDQ? Please let me explain it to you gradually. For a positive integer x, F(x) indicates the number of kind of prime factor of x. For example F(2)=1. F(10)=2, because 10=2*5. F(12)=2, because 12=2*2*3, there are two kinds of prime factor. For each query, we will get an interval [L, R], Hdu wants to know maxGCD(F(i),F(j)) (Li<jR)

Input
There are multiple queries. In the first line of the input file there is an integer T indicates the number of queries.
In the next T lines, each line contains L, R which is mentioned above.

All input items are integers.
1<= T <= 1000000
2<=L < R<=1000000

Output
For each query,output the answer in a single line.
See the sample for more details.

Sample Input
2
2 3
3 5
Sample Output
1
1
没有想到所有的数中最大才为7
直接构造二维前缀数组记录在它之前的各个个数的数目;

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
#include <list>
#include <algorithm>
#define RR freopen("output.txt","r",stdout)
#define WW freopen("input.txt","w",stdin)
typedef long long LL;

using namespace std;


const int MAX = 1000010;

int num[MAX];

int dp[MAX][8];

int main()
{
    memset(num,0,sizeof(num));
    memset(dp,0,sizeof(dp));
    for(int i=2; i<MAX; i++)//开始写成(i*i<MAX)了,手残
    {
        if(!num[i])
        {
            num[i]=1;
            for(int j=2; j*i<MAX; j++)
            {
                num[j*i]++;
            }
        }
    }
    dp[2][1]=1;
    for(int i=3; i<MAX; i++)
    {

        for(int j=1; j<=7; j++)
        {
            dp[i][j]=dp[i-1][j];
        }

        dp[i][num[i]]++;
    }

    int L,R;
    int T;
    int ans;
    int s[8];
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d %d",&L,&R);
        ans=0;
        for(int i=1; i<=7; i++)
        {
            s[i]=dp[R][i]-dp[L-1][i];
        }
        if(s[7]>=2)
        {
            ans=7;
        }
        else if(s[6]>=2)
        {
            ans=6;
        }
        else if(s[5]>=2)
        {
            ans=5;
        }
        else if(s[4]>=2)
        {
            ans=4;
        }
        else if(s[3]>=2)
        {
            ans=3;
        }
        else if(s[6]&&s[3])
        {
            ans=3;
        }
        else if(s[2]>=2)
        {
           ans=2;
        }
        else if(s[6]&&s[2])
        {
          ans=2;
        }
        else if(s[6]&&s[4])
        {
           ans=2;
        }
        else if(s[4]&&s[2])
        {
            ans=2;
        }
        else
        {
           ans=1;
        }
        printf("%d\n",ans);
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

转载于:https://www.cnblogs.com/juechen/p/4721949.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值