poj 2909 Goldbach's Conjecture

Goldbach's Conjecture
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8274 Accepted: 4779

Description

For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that

n = p1 + p2

This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. There can be many such numbers. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.

Input

An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 215. The end of the input is indicated by a number 0.

Output

Each output line should contain an integer number. No other characters should appear in the output.

Sample Input

6
10
12
0

Sample Output

1
2
1
#include<iostream>
#include<cmath>
using namespace std;

const int maxsize=32768;
int prime[maxsize];

int isPrime(int n)
{
int i;
if(n!=2&&n%2==0)
return 0;
for(i=3;i<=sqrt(n*1.0);i+=2)
{
if(n%i==0)
return 0;
}
return 1;
}
void judge()
{
int i,j;
for(i=2,j=0;i<=33000;i++)
{
if(isPrime(i)==1)
{
prime[j]=i;
j++;
}
}
}
int main()
{
int n;
int i,j;
int count;
judge();
while(1)
{
cin>>n;
if(n==0)
break;
count=0;
for(i=0;i<maxsize;i++)
{
for(j=i;j<maxsize;j++)
{
if(prime[i]+prime[j]==n)
count++;
if(prime[i]+prime[j]>n)
break;
}
if(prime[i]*2>n)
break;
}
cout<<count<<endl;
}
return 0;
}
 

转载于:https://www.cnblogs.com/w0w0/archive/2011/11/22/2258737.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值