HIT1917Peaceful Commission(2-SAT)

Peaceful Commission

 Source : POI 2001
 Time limit : 10 sec Memory limit : 32 M

Submitted : 2112, Accepted : 641

The Public Peace Commission should be legislated in Parliament of The Democratic Republic of Byteland according to The Very Important Law. Unfortunately one of the obstacles is the fact that some deputies do not get on with some others.

The Commission has to fulfill the following conditions:

 

  • Each party has exactly one representative in the Commission,
  • If two deputies do not like each other, they cannot both belong to the Commission.

Each party has exactly two deputies in the Parliament. All of them are numbered from 1 to 2n. Deputies with numbers 2i-1 and 2i belong to the i-th party .

Task

Write a program, which:

 

  • reads from the text file SPO.IN the number of parties and the pairs of deputies that are not on friendly terms,
  • decides whether it is possible to establish the Commission, and if so, proposes the list of members,
  • writes the result in the text file SPO.OUT.

Input

In the first line of the text file SPO.IN there are two non-negative integers n and m. They denote respectively: the number of parties, 1 <= n <= 8000, and the number of pairs of deputies, who do not like each other, 0 <= m <=2 0000. In each of the following m lines there is written one pair of integers a and b, 1 <= a < b <= 2n, separated by a single space. It means that the deputies a and b do not like each other.

There are multiple test cases. Process to end of file.

Output

The text file SPO.OUT should contain one word NIE (means NO in Polish), if the setting up of the Commission is impossible. In case when setting up of the Commission is possible the file SPO.OUT should contain n integers from the interval from 1 to 2n, written in the ascending order, indicating numbers of deputies who can form the Commission. Each of these numbers should be written in a separate line. If the Commission can be formed in various ways, your program may write any of them.

Sample Input

 

3 2
1 3
2 4

Sample Output

 

1
4
5

题意同hdu1814
只是这个更简单,无比较字典序

题目大意

和平委员会

根据宪法,Byteland民主共和国的公众和平委员会应该在国会中通过立法程序来创立。 不幸的是,由于某些党派代表之间的不和睦而使得这件事存在障碍。

此委员会必须满足下列条件:

  • 每个党派都在委员会中恰有1个代表,
  • 如果2个代表彼此厌恶,则他们不能都属于委员会。

每个党在议会中有2个代表。代表从1编号到2n。 编号为2i-1和2i的代表属于第I个党派。

任务

写一程序:

  • 从文本文件读入党派的数量和关系不友好的代表对,
  • 计算决定建立和平委员会是否可能,若行,则列出委员会的成员表,
  • 结果写入文本文件。

输入

在文本文件的第一个行有2非负整数n和m。 他们各自表示:党派的数量n,1 < =n < =8000和不友好的代表对m,0 <=m <=20000。 在下面m行的每行为一对整数a,b,1<=a <b<=2n,中间用单个空格隔开。 它们表示代表a,b互相厌恶。

输出

如果委员会不能创立,文本文件中应该包括单词NIE。若能够成立,文本文件SPO.OUT中应该包括n个从区间1到2n选出的整数,按升序写出,每行一个,这些数字为委员会中代表的编号。如果委员会能以多种方法形成,程序可以只写他们的某一个。

样品输入

3 2
1 3
2 4

样品输出

1
4
5

人生第一次2-SAT
/*
2-SAT模板
无比较字典序
Tarjan缩点+拓扑排序+二分图染色 
*/ 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#define maxn 16010
using namespace std;

struct node
{
    int next,to;
} e[maxn<<4];
node edge[maxn<<4];
int n,m,t,cnt1,top,cnt,tt;
int head[maxn],dfn[maxn],low[maxn],belong[maxn],col[maxn],stack[maxn];
bool in_stack[maxn];
int in[maxn],Head[maxn],conflict[maxn],ans[maxn];

void add(int u,int v)
{
    e[t].to=v;
    e[t].next=head[u];
    head[u]=t++;
}

void add2(int u,int v)
{
    edge[tt].to=v;
    edge[tt].next=Head[u];
    Head[u]=tt++;
}

void Tarjan(int u)
{
    int t;
    stack[top++]=u;
    dfn[u]=low[u]=++cnt;
    in_stack[u]=true;
    for(int i=head[u];i!=-1;i=e[i].next)
    {
        int v=e[i].to;
        if(!dfn[v])
        {
            Tarjan(v);
            low[u]=min(low[u],low[v]);
        }
        else if(in_stack[v])
            low[u]=min(dfn[v],low[u]);
    }
    if(low[u]==dfn[u])//缩点 
    {
        cnt1++;
        do
        {
            t=stack[--top];
            belong[t]=cnt1;//belong[i]表示属于哪个缩点 
            in_stack[t]=false;
        }while(t!=u);
    }
}

bool solve()
{
    for(int i=0;i<2*n;i++)
        if(!dfn[i]) Tarjan(i);
    for(int i=0; i<2*n; i++)
    {
        if(belong[i]==belong[i^1])
            return false;
        conflict[belong[i]]=belong[i^1]; 
        conflict[belong[i^1]]=belong[i];//处理冲突节点
    }
    memset(in,0,sizeof(in));
    memset(col,0,sizeof(col));
    for(int i=0;i<2*n;i++)
    {
        for(int j=head[i];j!=-1;j=e[j].next)
        {
            int u=e[j].to;
            if(belong[i]!=belong[u])
            {
                add2(belong[u],belong[i]);//新建图
                in[belong[i]]++;
            }
        }
    }
    queue<int>q;//对新图进行拓扑
    for(int i=1;i<=cnt1;i++)
        if(in[i]==0) q.push(i);
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        if(col[u]==0)//染色 
        {
            col[u]=1;
            col[conflict[u]]=-1;
        }
        for(int i=Head[u];i!=-1;i=edge[i].next)
        {
            int v=edge[i].to;
            in[v]--;//入度 
            if(in[v]==0) q.push(v);
        }
    }
    memset(ans,0,sizeof(ans));
    for(int i=0;i<2*n;i++)
        if(col[belong[i]]==1) ans[i]=1;
    return true;
}

void start()
{
    memset(low,0,sizeof low);
    memset(dfn,0,sizeof dfn);
    memset(stack,0,sizeof stack);
    memset(in_stack,false,sizeof in_stack);
    memset(conflict,0,sizeof conflict);
    memset(head,-1,sizeof head);
    memset(Head,-1,sizeof Head);
    memset(e,0,sizeof e);
    memset(edge,0,sizeof edge);
    memset(belong,0,sizeof belong);
    cnt=0;top=0;cnt1=0;t=0;tt=0;
}

int main()
{
    int a,b;
    while(scanf("%d%d",&n,&m)==2)
    {
        start();
        while(m--)
        {
            scanf("%d%d",&a,&b);
            a--,b--;
            add(a,b^1);
            add(b,a^1);
        }
        if(solve())
        {
            for(int i=0;i<2*n;i++)
                if(ans[i]) printf("%d\n",i+1);
        }
        else printf("NIE\n");
    }
    return 0;
}

 

 
 

转载于:https://www.cnblogs.com/L-Memory/p/6681837.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值