POJ 2656 Unhappy Jinjin

时间限制: 
1000ms
内存限制:  
65536kB
描述
Jinjin is a junior school student. Besides the classes in school, Jinjin's mother also arranges some supplementary classes for her. However, if Jinjin studies for more than eight hours a day, she will be unhappy on that day. On any day she gets unhappy, the more time she studies, the unhappier she will be. Now we got Jinjin's class schedule for the next several days and your task is to find out whether she will be unhappy on these days; if she will be unhappy, on which day she will be the unhappiest.
输入
There may be several test cases. In the first line of each test case, there is an integer N (1 <= N <= 7), which represents the number of days you should analyze. Then there comes N lines, each contains two non-negative integers (each smaller than 10). The first integer represents how many hours Jinjin studies at school on the day, and the second represents how many hours she studies in the supplementary classes on the same day.

A case with N = 0 indicates the end of the input, and this case should not be processed.
输出
For each test case, output a line contains a single integer. If Jinjin will always be happy, the integer should be 0; otherwise, the integer should be a positive integer K, which means that Jinjin will be the unhappiest on the K-th day. If the unhappiest day is not unique, just output the earliest one among these unhappiest days.
样例输入
75 36 27 25 35 40 40 614 40
样例输出
30
 
(1)、源代码:
#include   <iostream>
using   namespace   std;
 
int   main(){
                 int   i, n, a, b;
 
                 while (1){
                                cin >> n;
                                 if (0 == n)
                                                 break ;
                                 int   mday, mhour = -1;
                                 for (i = 1; i <=n ; i++){
                                                cin >> a >> b;
                                                 if (a+b > mhour){
                                                                mhour = a+b;
                                                                mday = i;
                                                }
                                }
                                 if (mhour <=8)
                                                cout <<   "0\n" ;
                                 else
                                                cout << mday << endl;
                }
                 return   0;
}
  
(2)、可能出错:略
(3)、解题思路:略

转载于:https://www.cnblogs.com/lydf-2012/archive/2012/05/11/2496636.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值