ZOJ 3822 Domination 概率DP


概率DP


Domination

Time Limit: 8 Seconds       Memory Limit: 131072 KB       Special Judge

Edward is the headmaster of Marjar University. He is enthusiastic about chess and often plays chess with his friends. What's more, he bought a large decorative chessboard with N rows and M columns.

Every day after work, Edward will place a chess piece on a random empty cell. A few days later, he found the chessboard was dominated by the chess pieces. That means there is at least one chess piece in every row. Also, there is at least one chess piece in every column.

"That's interesting!" Edward said. He wants to know the expectation number of days to make an empty chessboard of N × M dominated. Please write a program to help him.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There are only two integers N and M (1 <= NM <= 50).

Output

For each test case, output the expectation number of days.

Any solution with a relative or absolute error of at most 10-8 will be accepted.

Sample Input
2
1 3
2 2
Sample Output
3.000000000000
2.666666666667

Author:  JIANG, Kai
Source:  The 2014 ACM-ICPC Asia Mudanjiang Regional Contest
Submit     Status


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;

const double eps = 1e-8;

int n,m;
double ans;
double dp[3000][60][60];

int main()
{
    int T_T;
    scanf("%d",&T_T);
    while(T_T--)
    {
        scanf("%d%d",&n,&m);
        ans=0.0;
        memset(dp,0,sizeof(dp));
        dp[1][1][1]=1.;
        for(int num=1;num<n*m;num++)
        {
            for(int r=0;r<=n;r++)
            {
                for(int c=0;c<=m;c++)
                if(r*c>=num)
                {
                    if(r==n&&c==m) continue;
                    int one = r*c-num;
                    int two = c*n-r*c;
                    int three = r*m-r*c;
                    int four = n*m - r*m - c*n + r*c;
                    int all = n*m - num;
                    dp[num+1][r][c]+=dp[num][r][c]*(one*1./all);
                    dp[num+1][r+1][c]+=dp[num][r][c]*(two*1./all);
                    dp[num+1][r][c+1]+=dp[num][r][c]*(three*1./all);
                    dp[num+1][r+1][c+1]+=dp[num][r][c]*(four*1./all);
                }
            }
        }
        for(int i=1;i<=n*m;i++)
            ans+=dp[i][n][m]*i;

        printf("%.10lf\n",ans);
    }
    return 0;
}


转载于:https://www.cnblogs.com/wzjhoutai/p/6784678.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值