Counting Sheep

  • Counting Sheep
  • 题目描述:
  • 共有n(n<=20)组数据,其中每组数据有一个正整数m(m<=10),然后是m个单词,统计其中有多少个“sheep”。单词大小写敏感,因而“sheep”等不匹配。
  • 输入样例:
  • 4
  • 5
  • shep sheep sheep ship Sheep
  • 7
  • sheep sheep SHEEP sheep shepe shemp seep
  • 10
  • sheep sheep sheep sheep sheep sheep sheep sheep sheep sheep
  • 4
  • shape buffalo ram goat
  • 输出样例:
  • Case 1:This list contains 1 sheep.
  • Case 2:This list contains 3 sheep.
  • Case 3:This list contains 10 sheep.
  • Case 4:This list contains 0 sheep.

参考答案:

#include<iostream>
#include<string>
using namespace std;
int main(){
    int n,m,c = 1,count;
    string str;
    cin>>n;
    while(n--){
        if(c > 1) cout<<endl;   //相邻两行之间输出一个空行 
        cin>>m;     //输入没次输入的单词数 
        count = 0;      //计数器,记录输入了多少个sheep 
        for(int i = 0; i < m; i++){
            cin>>str;
            if(str == "sheep") count++;
        }
        cout<<"Case"<<c++<<":This list contains "<<count<<" sheep."<<endl;
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/zhaoyulong/p/Dragon_Yu.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值