HDU1019 Least Common Multiple(多个数的最小公倍数)

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105. 

InputInput will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer. 
OutputFor each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer. 
Sample Input

2
3 5 7 15
6 4 10296 936 1287 792 1

Sample Output

105
10296

这道题挺简单的,但我居然想着去分解质因数然后乘一遍,又果断的TLE了.但其实真的很简单,不断地读入一个数,然后求它和之前所有数的lcm,这个怎么求呢?除去两数的gcd即可.说起来还是太菜了....

代码如下:
#include<cstdio>
using namespace std;

long long ans=1,n,i,x;

long long gcd(long long a,long long b)
{
    if(b>a)
    {
        long long w=a;a=b;b=w;
    }
    if(a%b==0)
    {
        return b;
    }
    else
    {
        return gcd(b,a%b);
    }
}

int main()
{
    long long t;
    scanf("%lld",&t);
    while(t--)
    {
        ans=1;
        scanf("%lld",&n);
        for(i=1;i<=n;i++)
        {
            scanf("%lld",&x);
            ans*=x/gcd(ans,x);
        }
        printf("%lld\n",ans);
    }
    return 0;
}

 

 

 

 

 

每日刷题身体棒棒!

转载于:https://www.cnblogs.com/stxy-ferryman/p/7470758.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值