ZOJ 2352 Scrambled Polygon



Scrambled Polygon

Time Limit: 2 Seconds       Memory Limit: 65536 KB

A closed polygon is a figure bounded by a finite number of line segments. The intersections of the bounding line segments are called the vertices of the polygon. When one starts at any vertex of a closed polygon and traverses each bounding line segment exactly once, one comes back to the starting vertex.

A closed polygon is called convex if the line segment joining any two points of the polygon lies in the polygon. Figure 1 shows a closed polygon which is convex and one which is not convex. (Informally, a closed polygon is convex if its border doesn't have any "dents".)

ZOJ 2352 Scrambled Polygon - qhn999 - 码代码的猿猿

The subject of this problem is a closed convex polygon in the coordinate plane, one of whose vertices is the origin (x = 0, y = 0). Figure 2 shows an example. Such a polygon will have two properties significant for this problem.

The first property is that the vertices of the polygon will be confined to three or fewer of the four quadrants of the coordinate plane. In the example shown in Figure 2, none of the vertices are in the second quadrant (where x < 0, y > 0).

To describe the second property, suppose you "take a trip" around the polygon: start at (0, 0), visit all other vertices exactly once, and arrive at (0, 0). As you visit each vertex (other than (0, 0)), draw the diagonal that connects the current vertex with (0, 0), and calculate the slope of this diagonal. Then, within each quadrant, the slopes of these diagonals will form a decreasing or increasing sequence of numbers, i.e., they will be sorted. Figure 3 illustrates this point.

ZOJ 2352 Scrambled Polygon - qhn999 - 码代码的猿猿 
ZOJ 2352 Scrambled Polygon - qhn999 - 码代码的猿猿

Input

The input file lists the vertices of a closed convex polygon in the plane. The number of lines in the input file will be at least three but no more than 50. Each line contains the x and y coordinates of one vertex. Each x and y coordinate is an integer in the range -999..999. The vertex on the first line of the input file will be the origin, i.e., x = 0 and y = 0. Otherwise, the vertices may be in a scrambled order. Except for the origin, no vertex will be on the x-axis or the y-axis. No three vertices are colinear.

Output

The output lists the vertices of the given polygon, one vertex per line. Each vertex from the input appears exactly once in the output. The origin (0,0) is the vertex on the first line of the output. The order of vertices in the output will determine a trip taken along the polygon's border, in the counterclockwise direction. The output format for each vertex is (x,y) as shown below.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Sample Input

1

0 0
70 -50
60 30
-30 -50
80 20
50 -60
90 -20
-30 -40
-10 -60
90 10

Sample Output

(0,0)
(-30,-40)
(-30,-50)
(-10,-60)
(50,-60)
(70,-50)
(90,-20)
(90,10)
(80,20)
(60,30)


Source:  Rocky Mountain 2004 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

struct node
{
    double x,y;
    double dt;
}p[111];

node BASIC;

double cross(node s,node a,node b)
{
    return (a.x-s.x)*(b.y-s.y)-(a.y-s.y)*(b.x-s.x);
}

bool cmp1(node a,node b)
{
    return cross(BASIC,a,b)>0;
}

int main()
{
    int T;
    cin>>T;
    bool first=true;
while(T--)
{
    int a,b;
    if(first)
    {
        cin>>a>>b;
        first=false;
    }
    p[0].x=p[0].y=0;
    BASIC=p[0];
    int cnt=1;
    while(cin>>a>>b)
    {
        if(a==0&&b==0) break;
        p[cnt].x=a; p[cnt].y=b;
        cnt++;
    }

    sort(p+1,p+cnt,cmp1);

    for(int i=0;i<cnt;i++)
    {
        cout<<"("<<p .x<<","<<p.y<<")"<<endl;
    }
    if(T!=0)
        cout<<endl;
}
    return 0;
}

转载于:https://www.cnblogs.com/CKboss/p/3350918.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值