gdcpc2015B题

题目名称:Base64

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5237(在hdu上的地址)


Problem Description
Mike does not want others to view his messages, so he find a encode method Base64.

Here is an example of the note in Chinese Passport.

The Ministry of Foreign Affairs of the People's Republic of China requests all civil and military authorities of foreign countries to allow the bearer of this passport to pass freely and afford assistance in case of need.

When encoded by \texttt{Base64}, it looks as follows

VGhlIE1pbmlzdHJ5IG9mIEZvcmVpZ24gQWZmYWlycyBvZiB0aGUgUGVvcGxlJ3MgUmVwdWJsaWMgb2Yg
Q2hpbmEgcmVxdWVzdHMgYWxsIGNpdmlsIGFuZCBtaWxpdGFyeSBhdXRob3JpdGllcyBvZiBmb3JlaWdu
IGNvdW50cmllcyB0byBhbGxvdyB0aGUgYmVhcmVyIG9mIHRoaXMgcGFzc3BvcnQgdG8gcGFzcyBmcmVl
bHkgYW5kIGFmZm9yZCBhc3Npc3RhbmNlIGluIGNhc2Ugb2YgbmVlZC4=

In the above text, the encoded result of \texttt{The} is \texttt{VGhl}. Encoded in ASCII, the characters \texttt{T}, \texttt{h}, and \texttt{e} are stored as the bytes  84104, and  101, which are the  8-bit binary values  0101010001101000, and  01100101. These three values are joined together into a 24-bit string, producing  010101000110100001100101.
Groups of  6 bits ( 6 bits have a maximum of  26=64 different binary values) are converted into individual numbers from left to right (in this case, there are four numbers in a 24-bit string), which are then converted into their corresponding Base64 encoded characters. The Base64 index table is

0123456789012345678901234567890123456789012345678901234567890123
ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789+/

In the above example, the string  010101000110100001100101 is divided into four parts  010101000110100001 and  100101, and converted into integers  21,6,33 and  37. Then we find them in the table, and get V, G, h, l.

When the number of bytes to encode is not divisible by three (that is, if there are only one or two bytes of input for the last 24-bit block), then the following action is performed:

Add extra bytes with value zero so there are three bytes, and perform the conversion to base64. If there was only one significant input byte, only the first two base64 digits are picked (12 bits), and if there were two significant input bytes, the first three base64 digits are picked (18 bits). '=' characters are added to make the last block contain four base64 characters.

As a result, when the last group contains one bytes, the four least significant bits of the final 6-bit block are set to zero; and when the last group contains two bytes, the two least significant bits of the final 6-bit block are set to zero.

For example, base64(A) = QQ==, base64(AA) = QUE=.

Now, Mike want you to help him encode a string for  k times. Can you help him?

For example, when we encode A for two times, we will get base64(base64(A)) = UVE9PQ==.
 


Input
  The first line contains an integer  T( T20) denoting the number of test cases.
  
  In the following  T lines, each line contains a case. In each case, there is a number  k(1k5) and a string  ss only contains characters whose ASCII value are from  33 to  126(all visible characters). The length of  s is no larger than  100.
 


Output
  For each test case, output Case #t:, to represent this is t-th case. And then output the encoded string.
 


Sample Input
2 1 Mike 4 Mike
 


Sample Output
Case #1: TWlrZQ== Case #2: Vmtaa2MyTnNjRkpRVkRBOQ==
 

代码如下:

 

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<string>
using namespace std;
char a[]= "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789+/";
int main()
{
    int t,k,cnt=1;
    while(scanf("%d",&t)!=EOF)
    {
        while(t--)
        {
            string s;
            cin>>k>>s;
            while(k--)
            {
                string bit="";
                int len=s.length();
                s[len]=s[len+1]=s[len+2]=0;  //三个字符刚好转换,所以补足位数
                for(int i=0;i<(len-1)/3+1;i++)
                {
                    int z=(((int)s[3*i])<<16)+(((int)s[3*i+1])<<8)+(int)s[3*i+2]; //三个字符转换成24位
                    char d[5]="";
                    for(int j=3;j>=0;j--)
                    {
                        d[j]=a[z%64];
                        z>>=6;
                    }
                    bit+=d;
                }
                int r=bit.length();
                if(len%3==1)         //后面少两个字符,补两个'='
                    bit[r-1]=bit[r-2]='=';
                if(len%3==2)         //后面少一个字符,补一个'='
                    bit[r-1]='=';
                s=bit;
            }
            printf("Case #%d: ",cnt++);
            cout<<s<<endl;
        }
    }
    return 0;
}

 

 


 

转载于:https://www.cnblogs.com/maplefighting/p/7375704.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值