洛谷 P2032 扫描

洛谷 P2032 扫描

Description

  • 有一个 1 ∗ n 的矩阵,有 n 个正整数。

    现在给你一个可以盖住连续的 k 的数的木板。

    一开始木板盖住了矩阵的第 1 ∼ k 个数,每次将木板向右移动一个单位,直到右端与第 n 个数重合。

    每次移动前输出被覆盖住的最大的数是多少。

Input

  • 第一行两个数,n,k,表示共有 n 个数,木板可以盖住 k 个数。

    第二行 n 个数,表示矩阵中的元素。

Output

  • 共 n − k + 1 行,每行一个正整数。

    第 i 行表示第 i ∼ i + k − 1 个数中最大值是多少。

Sample Input

5 3
1 5 3 4 2

Sample Output

5
5
4

Data Size

  • 对于 20% 的数据保证:1 ≤ n ≤ 1e3,1 ≤ k ≤ n

    对于 50% 的数据保证:1 ≤ n ≤ 1e4,1 ≤ k ≤ n

    对于 100% 的数据保证:1 ≤ n ≤ 2 ∗ 1e6,1 ≤ k ≤ n

    矩阵中元素大小不超过 1e4。

题解:

  • 单调队列。
  • 裸题,然后用优先队列做的QAQ。(注释的代码是单调队列解法
#include <iostream>
#include <cstdio>
#include <queue>
using namespace std;

struct Node
{
    int val, pos;
    friend bool operator < (Node x, Node y) {
        return x.val < y.val;
    }
};
int n, k;
priority_queue<Node> que;

int read()
{
    int x = 0; char c = getchar();
    while(c < '0' || c > '9') c = getchar();
    while(c >= '0' && c <= '9') {x = x * 10 + c - '0'; c = getchar();}
    return x;
}

int main()
{
    cin >> n >> k;
    for(int i = 1; i < k; i++) que.push((Node){read(), i});
    for(int i = k; i <= n; i++)
    {
        que.push((Node){read(), i});
        while(que.top().pos < i - k + 1 && que.size()) que.pop();
        printf("%d\n", que.top().val);
    }
    return 0;
}

/*
#include <iostream>
#include <cstdio>
#include <deque>
using namespace std;

struct Node {int val, pos;};
int n, k;
deque<Node> deq;

int read()
{
    int x = 0; char c = getchar();
    while(c < '0' || c > '9') c = getchar();
    while(c >= '0' && c <= '9') {x = x * 10 + c - '0'; c = getchar();}
    return x;
}

int main()
{
    freopen("P2032.in", "r", stdin);
    freopen("P2032.out", "w", stdout);

    cin >> n >> k;
    deq.push_back((Node){read(), 1});
    for(int i = 2; i < k; i++)
    {
        int x = read();
        while(deq.size() && deq.back().val <= x) deq.pop_back();
        deq.push_back((Node){x, i});
    }
    for(int i = k; i <= n; i++)
    {
        int x = read();
        while(deq.size() && deq.front().pos < i - k + 1) deq.pop_front();
        while(deq.size() && deq.back().val <= x) deq.pop_back();
        deq.push_back((Node){x, i});
        printf("%d\n", deq.front().val);
    }
    return 0;
}
*/

转载于:https://www.cnblogs.com/BigYellowDog/p/11439078.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值