UVALive - 4329 Ping pong (树状数组)

Ping pong

Description

N (3 ≤ N ≤ 20000) ping pong players live along a west-east street(consider the street as a line segment). Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee among other ping pong players and hold the game in the referee’s house. For some reason, the contestants can’t choose a referee whose skill rank is higher or lower than both of theirs. The contestants have to walk to the referee’s house, and because they are lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different, we call two games different. Now is the problem: how many different games can be held in this ping pong street?

Input

The first line of the input contains an integer T (1 ≤ T ≤ 20), indicating the number of test cases, followed by T lines each of which describes a test case. Every test case consists of N + 1 integers. The first integer is N, the number of players. Then N distinct integers a1, a2 . . . aN follow, indicating the skill rank of each player, in the order of west to east (1 ≤ ai ≤ 100000, i = 1 . . . N).

Output

For each test case, output a single line contains an integer, the total number of different games.

Sample Input

1

3 1 2 3

Sample Output

1

题意:一条大街上住着n个乒乓球爱好者,每个人有不同的技能值,现在要选三个人出来,一个裁判,两个选手,要求裁判的编号必须在两个选手之间,能力值也是如此,问你总方案数

分析:考虑第i个人当裁判,假设前面有c[i]个能力值比他小,那就有i-1-a[i]个比他大;同理,在后面有d[i]个比他小,就有n-i-d[i]个比他大,总方案数就是c[i]*(n-i-d[i])+d[i]*(i-1-c[i])种

求c[i]可用到hash思想,将a[i]映射到F[a[i]]上,1表示存在,0表示没有,这样用树状数组统计前缀和就行了。

 

#include<bits/stdc++.h>
using namespace std;

const int MAXN = 20000+100;
const int MAXE = 100000+100;
int F[MAXE],n;
int a[MAXN],c[MAXN],d[MAXN];

void update(int x,int val)
{
    while(x<MAXE)
    {
        F[x]+=val;
        x+=x&-x;
    }
}
int query(int x)
{
    int res=0;
    while(x>0)
    {
        res+=F[x];
        x-=x&-x;
    }
    return res;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        memset(F,0,sizeof(F));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            update(a[i],1);
            c[i]=query(a[i]-1);
        }
        memset(F,0,sizeof(F));
        for(int i=n;i>=1;i--)
        {
            update(a[i],1);
            d[i]=query(a[i]-1);
        }
        long long res=0;
        for(int i=1;i<=n;i++)
            res=res+(long long)c[i]*(n-i-d[i])+(long long)d[i]*(i-1-c[i]);
        printf("%lld\n",res);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/wangdongkai/p/5716881.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值