Poj 1149 Pigs

Poj 1149 Pigs

Mirko works on a pig farm that consists of M locked pig-houses and Mirko
can't unlock any pighouse because he doesn't have the keys. Customers
come to the farm one after another. Each of them has keys to some
pig-houses and wants to buy a certain number of pigs.
All data concerning customers planning to visit the farm on
that particular day are available to Mirko early in the morning so that
he can make a sales-plan in order to maximize the number of pigs sold.
More precisely, the procedure is as following: the customer
arrives, opens all pig-houses to which he has the key, Mirko sells a
certain number of pigs from all the unlocked pig-houses to him, and, if
Mirko wants, he can redistribute the remaining pigs across the unlocked
pig-houses.
An unlimited number of pigs can be placed in every pig-house.
Write a program that will find the maximum number of pigs that he can sell on that day.

Input

​ The first line of input contains two integers M and N, 1 <= M <= 1000, 1 <= N <= 100, number of pighouses and number of customers. Pig houses are numbered from 1 to M and customers are numbered from 1 to N.
The next line contains M integeres, for each pig-house initial number of pigs. The number of pigs in each pig-house is greater or equal to 0 and less or equal to 1000.
The next N lines contains records about the customers in the following form ( record about the i-th customer is written in the (i+2)-th line):
A K1 K2 ... KA B It means that this customer has key to the pig-houses marked with the numbers K1, K2, ..., KA (sorted nondecreasingly ) and that he wants to buy B pigs. Numbers A and B can be equal to 0.

Output

​ The first and only line of the output should contain the number of sold pigs.

Sample Input

3 3
3 1 10
2 1 2 2
2 1 3 3
1 2 6

Sample output

7

分析:本题的关键就在于如何构造一个容量网络。在本题中,容量网络的构造如下。

(1)将顾客看作除源点和汇点外以的结点,并且另设两个节点:源点和汇点。

(2)源点和每个猪圈的第一个顾客连边,边的权是开始时猪圈中猪的数目,若有重边则将边权合并(因此源点流出的流量就是所有的猪圈能提供的猪的数目)。

(3)若顾客j紧跟在顾客i之后打开某个猪圈,则边<i,j>的权是+∞;这是因为,如果顾客j紧跟在i之后打开某个猪圈,那么迈克就有可能根据顾客j的需求将其他猪圈中的猪调整到该猪圈,这样j就能买到尽可能多的猪

(5)每个顾客和汇点之间连边,边的权是顾客希望购买的猪的数目(因此汇点流入的量就是每个顾客所购买的猪的数目)。

这题数据量较小,采用一般增广路算法即可

#include<cstdio>
#include<algorithm>
#include<queue>
#include<cstring>
using namespace std;
const int INF = 0x3f3f3f3f;
const int INF2 = 300000000;
const int MAXM = 1005;
const int MAXN = 105;
struct Edge {
    int f,c;
};
Edge edge[MAXN][MAXN];
int n,v;
int house[MAXM],last[MAXM];
int flag[MAXN],pre[MAXN],alpha[MAXN];
queue<int > q;
void init() {
    int M,N,num,k;
    scanf("%d%d",&M,&N);
    n = N+2;
    memset(last,0,sizeof(last));
    memset(edge,0x3f,sizeof(edge));
    for(int i = 1;i <= M;i++) scanf("%d",&house[i]);
    for(int i = 1;i <= N;i++) {
        scanf("%d",&num);
        for(int j = 0;j < num;j++) {
            scanf("%d",&k);
            if(last[k] == 0) {
                if(edge[0][i].c == INF) edge[0][i].c = 0;
                edge[0][i].c+=house[k];
                edge[0][i].f = 0;
            }
            else {edge[last[k]][i].c = INF2;edge[last[k]][i].f = 0;}
            last[k] = i;
        }
        scanf("%d",&edge[i][n-1].c);
        edge[i][n-1].f = 0;
    }
    /*for(int i = 0;i < n;i++) {
        for(int j = 0;j < n;j++) 
            edge[i][j].f = 0;
    }*/
}
void ford() {
    for(;;) {
        memset(flag,0xff,sizeof(flag));
        memset(pre,0xff,sizeof(pre));
        flag[0] = 0;pre[0] = 0;alpha[0] = INF;
        while(!q.empty()) q.pop();
        q.push(0);
        while(!q.empty() && flag[n-1] == -1) {
            v = q.front();q.pop();
            for(int i = 0;i < n;i++) {
                if(flag[i] == -1) {
                    if(edge[v][i].c < INF && edge[v][i].f < edge[v][i].c) {
                        flag[i] = 0;pre[i] = v;
                        alpha[i] = min(alpha[v],edge[v][i].c - edge[v][i].f);
                        q.push(i);
                    }
                    else if(edge[i][v].c < INF && edge[i][v].f > 0) {
                        flag[i] = 0;pre[i] = -v;
                        alpha[i] = min(alpha[v],edge[i][v].f);
                        q.push(i);
                    }
                }
            }
            flag[v] = 1;
        }
        if(flag[n-1] == -1 || alpha[n-1] == 0) break;   
        int k1 = n-1,k2 = abs(pre[k1]);
        int a = alpha[n-1];
        while (1)
        {
            if(edge[k2][k1].f < INF) edge[k2][k1].f += a;
            else edge[k1][k2].f -= a;
            if(k2 == 0) break;
            k1 = k2;k2 = abs(pre[k2]);
        } 
    }
    int maxflow = 0;
    for(int i = 0;i < n;i++) {
        for(int j = 0;j < n;j++) {
            if(i == 0 && edge[i][j].f != INF) maxflow+=edge[i][j].f;
        }
    }
    /*for(int i = 0;i < n;i++) {
        for(int j = 0;j < n;j++) {
            if(i!=j) printf("%d %d\n",edge[i][j].c,edge[i][j].f);
        }
    }*/
    printf("%d\n",maxflow);
}
int main() {
    init();
    ford();
    return 0;
}

转载于:https://www.cnblogs.com/pot-a-to/p/10939739.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
完整版:https://download.csdn.net/download/qq_27595745/89522468 【课程大纲】 1-1 什么是java 1-2 认识java语言 1-3 java平台的体系结构 1-4 java SE环境安装和配置 2-1 java程序简介 2-2 计算机中的程序 2-3 java程序 2-4 java类库组织结构和文档 2-5 java虚拟机简介 2-6 java的垃圾回收器 2-7 java上机练习 3-1 java语言基础入门 3-2 数据的分类 3-3 标识符、关键字和常量 3-4 运算符 3-5 表达式 3-6 顺序结构和选择结构 3-7 循环语句 3-8 跳转语句 3-9 MyEclipse工具介绍 3-10 java基础知识章节练习 4-1 一维数组 4-2 数组应用 4-3 多维数组 4-4 排序算法 4-5 增强for循环 4-6 数组和排序算法章节练习 5-0 抽象和封装 5-1 面向过程的设计思想 5-2 面向对象的设计思想 5-3 抽象 5-4 封装 5-5 属性 5-6 方法的定义 5-7 this关键字 5-8 javaBean 5-9 包 package 5-10 抽象和封装章节练习 6-0 继承和多态 6-1 继承 6-2 object类 6-3 多态 6-4 访问修饰符 6-5 static修饰符 6-6 final修饰符 6-7 abstract修饰符 6-8 接口 6-9 继承和多态 章节练习 7-1 面向对象的分析与设计简介 7-2 对象模型建立 7-3 类之间的关系 7-4 软件的可维护与复用设计原则 7-5 面向对象的设计与分析 章节练习 8-1 内部类与包装器 8-2 对象包装器 8-3 装箱和拆箱 8-4 练习题 9-1 常用类介绍 9-2 StringBuffer和String Builder类 9-3 Rintime类的使用 9-4 日期类简介 9-5 java程序国际化的实现 9-6 Random类和Math类 9-7 枚举 9-8 练习题 10-1 java异常处理 10-2 认识异常 10-3 使用try和catch捕获异常 10-4 使用throw和throws引发异常 10-5 finally关键字 10-6 getMessage和printStackTrace方法 10-7 异常分类 10-8 自定义异常类 10-9 练习题 11-1 Java集合框架和泛型机制 11-2 Collection接口 11-3 Set接口实现类 11-4 List接口实现类 11-5 Map接口 11-6 Collections类 11-7 泛型概述 11-8 练习题 12-1 多线程 12-2 线程的生命周期 12-3 线程的调度和优先级 12-4 线程的同步 12-5 集合类的同步问题 12-6 用Timer类调度任务 12-7 练习题 13-1 Java IO 13-2 Java IO原理 13-3 流类的结构 13-4 文件流 13-5 缓冲流 13-6 转换流 13-7 数据流 13-8 打印流 13-9 对象流 13-10 随机存取文件流 13-11 zip文件流 13-12 练习题 14-1 图形用户界面设计 14-2 事件处理机制 14-3 AWT常用组件 14-4 swing简介 14-5 可视化开发swing组件 14-6 声音的播放和处理 14-7 2D图形的绘制 14-8 练习题 15-1 反射 15-2 使用Java反射机制 15-3 反射与动态代理 15-4 练习题 16-1 Java标注 16-2 JDK内置的基本标注类型 16-3 自定义标注类型 16-4 对标注进行标注 16-5 利用反射获取标注信息 16-6 练习题 17-1 顶目实战1-单机版五子棋游戏 17-2 总体设计 17-3 代码实现 17-4 程序的运行与发布 17-5 手动生成可执行JAR文件 17-6 练习题 18-1 Java数据库编程 18-2 JDBC类和接口 18-3 JDBC操作SQL 18-4 JDBC基本示例 18-5 JDBC应用示例 18-6 练习题 19-1 。。。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值