poj--2516--Minimum Cost(最小费用流)

Minimum Cost
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 15340 Accepted: 5304

Description

Dearboy, a goods victualer, now comes to a big problem, and he needs your help. In his sale area there are N shopkeepers (marked from 1 to N) which stocks goods from him.Dearboy has M supply places (marked from 1 to M), each provides K different kinds of goods (marked from 1 to K). Once shopkeepers order goods, Dearboy should arrange which supply place provide how much amount of goods to shopkeepers to cut down the total cost of transport.

It's known that the cost to transport one unit goods for different kinds from different supply places to different shopkeepers may be different. Given each supply places' storage of K kinds of goods, N shopkeepers' order of K kinds of goods and the cost to transport goods for different kinds from different supply places to different shopkeepers, you should tell how to arrange the goods supply to minimize the total cost of transport.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, K (0 < N, M, K < 50), which are described above. The next N lines give the shopkeepers' orders, with each line containing K integers (there integers are belong to [0, 3]), which represents the amount of goods each shopkeeper needs. The next M lines give the supply places' storage, with each line containing K integers (there integers are also belong to [0, 3]), which represents the amount of goods stored in that supply place.

Then come K integer matrices (each with the size N * M), the integer (this integer is belong to (0, 100)) at the i-th row, j-th column in the k-th matrix represents the cost to transport one unit of k-th goods from the j-th supply place to the i-th shopkeeper.

The input is terminated with three "0"s. This test case should not be processed.

Output

For each test case, if Dearboy can satisfy all the needs of all the shopkeepers, print in one line an integer, which is the minimum cost; otherwise just output "-1".

Sample Input

1 3 3   
1 1 1
0 1 1
1 2 2
1 0 1
1 2 3
1 1 1
2 1 1

1 1 1
3
2
20

0 0 0

Sample Output

4
-1

Source

POJ Monthly--2005.07.31, Wang Yijie
送货问题,现在又n个店m个仓库k种商品,输入中有n*k的矩阵,表示每一位商家对每种商品的需求,然后是m*k的矩阵,表示每一个仓库中各种商品的储存量,最后是k个n*m的矩阵,n*m的矩阵中,i行j列表示第k种商品从j到i的花费,求最少的路费
建立超级源点跟超级汇点
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<algorithm>
using namespace std;
#define MAXN 200
#define MAXM 10000+10
#define INF 0x3f3f3f3f
struct node
{
	int from,to,cap,flow,cost,next;
}edge[MAXM];
int head[MAXN],top,dis[MAXN],pre[MAXN];
bool vis[MAXN];
int source,sink;
int n,m,k;
int need[60][60];
int have[60][60];
int Sneed[60],Shave[60];
int used[60][60];
bool flag;
void init()
{
	top=0;
	memset(head,-1,sizeof(head));
}
void add(int a,int b,int w,int c)
{
	node E1={a,b,w,0,c,head[a]};
	edge[top]=E1;
	head[a]=top++;
	node E2={b,a,0,0,-c,head[b]};
	edge[top]=E2;
	head[b]=top++;
}
bool SPFA(int s,int t)
{
	queue<int>q;
	memset(dis,INF,sizeof(dis));
	memset(vis,false,sizeof(vis));
	memset(pre,-1,sizeof(pre));
	dis[s]=0;
	vis[s]=true;
	q.push(s);
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		vis[u]=false;
		for(int i=head[u];i!=-1;i=edge[i].next)
		{
			node E=edge[i];
			if(dis[E.to]>dis[u]+E.cost&&E.cap>E.flow)
			{
				dis[E.to]=dis[u]+E.cost;
				pre[E.to]=i;
				if(!vis[E.to])
				{
					vis[E.to]=true;
					q.push(E.to);
				}
			}
		}
	}
	return pre[t]!=-1;
}
int MCMF(int s,int t,int &cost,int &flow)
{
	cost=flow=0;
	while(SPFA(s,t))
	{
		int Min=INF;
		for(int i=pre[t];i!=-1;i=pre[edge[i^1].to])
		{
			node E=edge[i];
			Min=min(Min,E.cap-E.flow);
		}
		for(int i=pre[t];i!=-1;i=pre[edge[i^1].to])
		{
			edge[i].flow+=Min;
			edge[i^1].flow-=Min;
			cost+=edge[i].cost*Min;
		}
		flow+=Min;
	}
	return flow;
}
void solve()
{
	memset(Sneed,0,sizeof(Sneed));
	memset(Shave,0,sizeof(Shave));
	for(int i=1;i<=n;i++)
	{
		for(int j=1;j<=k;j++)
		{
			scanf("%d",&need[i][j]);
			Sneed[j]+=need[i][j];
		}
	}
	for(int i=1;i<=m;i++)
	{
		for(int j=1;j<=k;j++)
		{
			scanf("%d",&have[i][j]);
			Shave[j]+=have[i][j];
		}
	}
	flag=true;
	for(int i=1;i<=k;i++)
	{
		if(Shave[i]<Sneed[i])
		{
			flag=false;
			break;
		}
	}
	int ans=0;
	int cost,flow;
	for(int j=1;j<=k;j++)
	{
		for(int i=1;i<=n;i++)
		{
			for(int s=1;s<=m;s++)
			scanf("%d",&used[i][s]);
		}
		if(!flag) continue;
		init();
		source=0,sink=n+m+1;
		for(int i=1;i<=n;i++)
			add(i,sink,need[i][j],0);
		for(int i=1;i<=m;i++)
			add(source,i+n,have[i][j],0);
		for(int i=1;i<=m;i++)
		for(int s=1;s<=n;s++)
		add(i+n,s,INF,used[s][i]);
		MCMF(source,sink,cost,flow);
		if(flow!=Sneed[j])
			flag=false;
		else
			ans+=cost;
	}
	if(flag)
		printf("%d\n",ans);
	else
		printf("-1\n");
}
int main()
{
	while(scanf("%d%d%d",&n,&m,&k),m||m||k)
	{
		solve();
	}
	return 0;
}


转载于:https://www.cnblogs.com/playboy307/p/5273466.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值