Poj3414广搜

<span style="color:#330099;">/*
D - D
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit
 
Status
 
Practice
 
POJ 3414
Description
You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:

FILL(i)        fill the pot i (1 ≤ i ≤ 2) from the tap;
DROP(i)      empty the pot i to the drain;
POUR(i,j)    pour from pot i to pot j; after this operation either the pot j is full (and there may be some water left in the pot i), or the pot i is empty (and all its contents have been moved to the pot j).
Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.

Input
On the first and only line are the numbers A, B, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).

Output
The first line of the output must contain the length of the sequence of operations K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.

Sample Input
3 5 4
Sample Output
6
FILL(2)
POUR(2,1)
DROP(1)
POUR(2,1)
FILL(2)
POUR(2,1)
By Grant Yuan
2014.7.14
poj 3414
广搜
*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;
bool flag=0;
int next[6]={0,1,2,3,4,5};
int a,b,c;
int aa,bb,cc;
typedef struct{
  int a;
  int b;
  int f;
  int sum;
  int ope;
}node;
int res;
node q[10000];
bool mark[101][101];
int top,base;
int top1;
int s[10000];
bool can(int x1,int y1)
{
    if(x1>=0&&x1<=aa&&y1>=0&&y1<=bb&&mark[x1][y1]==0)
      return 1;
    return 0;
}

void slove()
{   int a1,b1,f1,a2,b2;
    while(top>=base){//cout<<"zhang"<<endl;
     if(q[base].a==cc||q[base].b==cc){
          flag=1;
           res=q[base].sum;
           break;
          }
      for(int i=0;i<6;i++){
          if(i==0)
            {  a1=aa;
               b1=q[base].b;
               if(can(a1,b1)){
                q[++top].a=a1;
                q[top].b=b1;
                q[top].f=base;
                q[top].sum=q[base].sum+1;
                q[top].ope=i;
                mark[a1][b1]=1;}

            }
            else if(i==1)
            {
               a1=q[base].a;
               b1=bb;
               if(can(a1,b1)){
                q[++top].a=a1;
                q[top].b=b1;
                q[top].f=base;
                q[top].sum=q[base].sum+1;
                q[top].ope=i;
                mark[a1][b1]=1;}
            }
            else if(i==2)//1dao2
            {  int m,n;
               m=q[base].a;
               n=bb-q[base].b;
               if(m>=n){
                   a1=m-n;
                   b1=bb;
                if(can(a1,b1)){
                q[++top].a=a1;
                q[top].b=b1;
                q[top].f=base;
                q[top].sum=q[base].sum+1;
                q[top].ope=i;
                mark[a1][b1]=1;} }
                else{
                  a1=0;
                  b1=m+q[base].b;
                  if(can(a1,b1)){
                q[++top].a=a1;
                q[top].b=b1;
                q[top].f=base;
                q[top].sum=q[base].sum+1;
                q[top].ope=i;
                mark[a1][b1]=1;}
                  }}
            else if(i==3)//1dao2
            {  int m,n;
               m=aa-q[base].a;
               n=q[base].b;
               if(n>=m){
                   a1=aa;
                   b1=n-m;
                if(can(a1,b1)){
                q[++top].a=a1;
                q[top].b=b1;
                q[top].f=base;
                q[top].sum=q[base].sum+1;
                q[top].ope=i;
                mark[a1][b1]=1;} }
                else{
                  b1=0;
                  a1=n+q[base].a;
                  if(can(a1,b1)){
                q[++top].a=a1;
                q[top].b=b1;
                q[top].f=base;
                q[top].sum=q[base].sum+1;
                q[top].ope=i;
                mark[a1][b1]=1;}
                  }}
               else if(i==4)
               {
                   a1=0;
                   b1=q[base].b;
                   if(can(a1,b1)){
                    q[++top].a=a1;
                    q[top].b=b1;
                    q[top].f=base;
                    q[top].sum=q[base].sum+1;
                     q[top].ope=i;
                     mark[a1][b1]=1;
                    }}
                else if(i==5)
               {
                   b1=0;
                   a1=q[base].a;
                   if(can(a1,b1)){
                    q[++top].a=a1;
                    q[top].b=b1;
                    q[top].f=base;
                    q[top].sum=q[base].sum+1;
                    q[top].ope=i;
                     mark[a1][b1]=1;
                    }
               }

        }
        base++;
}}
void print()
{   top1=-1;
    int i=base,j;
    while(1){
        s[++top1]=q[i].ope;
        j=q[i].f;
        i=j;
        if(i==0)
          break;
          }
    for(j=top1;j>=0;j--)
    {
        if(s[j]==0)
           cout<<"FILL(1)"<<endl;
        else
          if(s[j]==1)
           cout<<"FILL(2)"<<endl;
        else
           if(s[j]==2)
            cout<<"POUR(1,2)"<<endl;
        else
          if(s[j]==3)
            cout<<"POUR(2,1)"<<endl;
        else
          if(s[j]==4)
            cout<<"DROP(1)"<<endl;
        else
          if(s[j]==5)
            cout<<"DROP(2)"<<endl;
    }
}
int main()
{
    cin>>aa>>bb>>cc;
    top=-1;
    memset(mark,0,sizeof(mark));
    mark[0][0]=1;
    base=0;
    q[++top].a=0;
    q[top].b=0;
    q[top].f=0;
    q[top].sum=0;
    q[top].ope=0;
    slove();
    if(flag==0) cout<<"impossible"<<endl;
    else{cout<<res<<endl;
    print();}
    return 0;

}
</span>


转载于:https://www.cnblogs.com/codeyuan/p/4254522.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值