Hat’s Words

Hat’s Words

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5620    Accepted Submission(s): 2091

Problem Description
A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.
 

Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.
 

Output
Your output should contain all the hat’s words, one per line, in alphabetical order.
 

Sample Input
 
   
a ahat hat hatword hziee word
 

Sample Output
 
   
ahat hatword
 
字典树题目,WA了,10次,好多细节要考虑。哎,学习了。ACM要靠经验哦。
#include <iostream>
#include <string>
#include <vector>
using namespace std;
vector<string> hat;
struct dictree
{
	dictree *child[26];
	bool final;
	dictree()
	{
		memset(child,0,sizeof(child));
		final=false;
	}
};
dictree *root;
void insert(string source)
{
	dictree *current,*newnode;
	int len = source.length();
	if(!len)
		return ;
	current = root;
	for(int i=0;i<len;i++)
	{
		if(current->child[source[i]-'a']==0)
		{
			newnode = new dictree();
			current->child[source[i]-'a']=newnode;
		}
			current=current->child[source[i]-'a'];
	}
	current->final=true;
}
bool find(string source)
{
	dictree *current=root;
	for(int i=0;i<(int)source.size();i++)
	{
		if(current->child[source[i]-'a']!=0)
			current = current->child[source[i]-'a'];
		else
			return false;/*注意这个判断,WA了好几次的罪魁祸首啊。因为若少此一句,如果在某个终止结点处,source还没遍历完但是下一个不匹配。就会跳过这个字符去匹配下一个,好坑啊*/
	}
	return current->final;
}
int main()
{
	string temp;
	root=new dictree();
	while(cin>>temp)
	{
		insert(temp);
		hat.push_back(temp);
	}
	for(int j=0;j<(int)hat.size();j++)
	{
		string t=hat[j];
		unsigned len=t.size();
		for(int i=1;i!=len;i++)
		{
			string s1(t,0,i);
			string s2(t,i);
			if(find(s1)&&find(s2))
			{
					cout<<hat[j]<<endl;
					break;/*当满足条件是立刻跳出,否则可能会多次输出同一个
			}
		}
	}
	return 0;
}


转载于:https://www.cnblogs.com/unclejelly/p/4082144.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值