HDU - 5150 Sum Sum Sum

Sum Sum Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 166    Accepted Submission(s): 122


Problem Description
We call a positive number  X P-number if there is not a positive number that is less than  X and the greatest common divisor of these two numbers is bigger than 1.
Now you are given a sequence of integers. You task is to calculate the sum of P-numbers of the sequence.
 

Input
There are several test cases. 
In each test case:
The first line contains a integer  N(1N1000). The second line contains  N integers. Each integer is between 1 and 1000.
 

Output
For each test case, output the sum of P-numbers of the sequence.
 

Sample Input
 
  
3 5 6 7 1 10
 

Sample Output
 
  
12 0
 



#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>
using namespace std;

int gcd(int x, int y)
{
    return y==0 ? x : gcd(y, x % y);
}

bool is_p(int x)
{
    for(int i = 2; i < x; i++)
        if( gcd(x, i) >= 2 )
            return false;
    return true;
}

int main()
{
    int N;
    while(cin >> N)
    {
        int sum = 0;
        while(N--)
        {
            int x; cin >> x;
            if(is_p(x))
                sum += x;
        }
        printf("%d\n",sum);
    }
    return 0;
}


转载于:https://www.cnblogs.com/kunsoft/p/5312754.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值