P2922 [USACO08DEC]秘密消息Secret Message

题目描述

Bessie is leading the cows in an attempt to escape! To do this, the cows are sending secret binary messages to each other.

Ever the clever counterspy, Farmer John has intercepted the first b_i (1 <= b_i <= 10,000) bits of each of M (1 <= M <= 50,000) of these secret binary messages.

He has compiled a list of N (1 <= N <= 50,000) partial codewords that he thinks the cows are using. Sadly, he only knows the first c_j (1 <= c_j <= 10,000) bits of codeword j.

For each codeword j, he wants to know how many of the intercepted messages match that codeword (i.e., for codeword j, how many times does a message and the codeword have the same initial bits). Your job is to compute this number.

The total number of bits in the input (i.e., the sum of the b_i and the c_j) will not exceed 500,000.

Memory Limit: 32MB

POINTS: 270

贝茜正在领导奶牛们逃跑.为了联络,奶牛们互相发送秘密信息.

信息是二进制的,共有M(1≤M≤50000)条.反间谍能力很强的约翰已经部分拦截了这些信息,知道了第i条二进制信息的前bi(l《bi≤10000)位.他同时知道,奶牛使用N(1≤N≤50000)条密码.但是,他仅仅了解第J条密码的前cj(1≤cj≤10000)位.

对于每条密码J,他想知道有多少截得的信息能够和它匹配.也就是说,有多少信息和这条密码有着相同的前缀.当然,这个前缀长度必须等于密码和那条信息长度的较小者.

在输入文件中,位的总数(即∑Bi+∑Ci)不会超过500000.

输入输出格式

输入格式:

* Line 1: Two integers: M and N

* Lines 2..M+1: Line i+1 describes intercepted code i with an integer b_i followed by b_i space-separated 0's and 1's

* Lines M+2..M+N+1: Line M+j+1 describes codeword j with an integer c_j followed by c_j space-separated 0's and 1's

输出格式:

* Lines 1..M: Line j: The number of messages that the jth codeword could match.

输入输出样例

输入样例#1: 
4 5 
3 0 1 0 
1 1 
3 1 0 0 
3 1 1 0 
1 0 
1 1 
2 0 1 
5 0 1 0 0 1 
2 1 1 
输出样例#1: 
1 
3 
1 
1 
2 

说明

Four messages; five codewords.

The intercepted messages start with 010, 1, 100, and 110.

The possible codewords start with 0, 1, 01, 01001, and 11.

0 matches only 010: 1 match

1 matches 1, 100, and 110: 3 matches

01 matches only 010: 1 match

01001 matches 010: 1 match

11 matches 1 and 110: 2 matches

 

Solution:

  本题trie树,比较板子。

  题意就是给定一个字符串集,然后每次询问一个字符串是给定字符串集的前缀的个数+给定字符串集中字符串是该字符串的前缀的个数(语文不好,描述不清,自行YY)。

  如果是求有多少个字符串是某一字符串的前缀,那么就是模板,只需要用数组$end[p]$记录一下$p$指针作为字符串结尾的个数,然后在扫描trie树的时候累加$end$值就好了。

  对于本题,我们可以类似去做,再建立trie树时另用一个$f[p]$记录$p$指针经过了多少个字符串,询问时先用上面方法求出有多少个字符串是它的前缀(累加$end$值),最后扫描完后判断$end[p]$是否小于$f[p]$,小于说明$p$指针后面还有字符串,而询问的字符串必定是这些字符串的前缀,所以再累加个数$f[p]-end[p]$就好了。

代码:

 

#include<bits/stdc++.h>
#define il inline
#define ll long long
#define For(i,a,b) for(int (i)=(a);(i)<=(b);(i)++)
#define Bor(i,a,b) for(int (i)=(b);(i)>=(a);(i)--)
using namespace std;
const int N=1000005;
int trie[N][2],n,m,f[N],g[N],cnt=1;

il void insert(){
    int tot=0,p=1,x;
    scanf("%d",&tot);
    For(i,1,tot) {
        scanf("%d",&x);
        if(!trie[p][x]) trie[p][x]=++cnt;
        p=trie[p][x],f[p]++;
    }
    g[p]++;
}

il int search(){
    int tot=0,p=1,x,ans=0,la=0;
    scanf("%d",&tot);
    For(i,1,tot){
        scanf("%d",&x);
        if(p){
            p=trie[p][x];
            if(g[p]) ans+=g[p];
        }
    }
    if(g[p]!=f[p]) ans+=f[p]-g[p];
    return ans;
}

int main(){
    scanf("%d%d",&n,&m);
    For(i,1,n) insert();
    For(i,1,m) printf("%d\n",search()); 
    return 0;
}

 

 

 

 

转载于:https://www.cnblogs.com/five20/p/9437180.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值