[kuangbin带你飞]专题十六 KMP & 扩展KMP & Manacher :G - Power Strings POJ - 2406(kmp简单循环节)...

[kuangbin带你飞]专题十六 KMP & 扩展KMP & Manacher

G - Power Strings

POJ - 2406

题目:

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.
题意:求字符串的循环节个数
思路:要注意如果该字符串如果不满足都是循环组成的则输出-1,若是都是循环节组成的,那么n-nextt[n]就是循环节长度,用总长度除以这个长度就是循环节长度
 
// 
// Created by HJYL on 2019/8/15.
//
#include <iostream>
#include <vector>
#include <map>
#include <string>
#include <queue>
#include <stack>
#include <set>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
using namespace std;
const int maxn=1e7+10;
char str[maxn];
int nextt[maxn];
void getnextt()
{
    int i=0,j=-1;
    nextt[0]=-1;
    int n=strlen(str);
    while(i<n)
    {
        if(j==-1||str[i]==str[j])
        {
            i++,j++;
            if(str[i]!=str[j])
                nextt[i]=j;
            else
                nextt[i]=nextt[j];
        } else
            j=nextt[j];
    }
}
int main()
{
    //freopen("C:\\Users\\asus567767\\CLionProjects\\untitled\\text","r",stdin);
    while(~scanf("%s",str))
    {
        if(str[0]=='.')
            break;
        int len=strlen(str);
        getnextt();
        if(len%(len-nextt[len])==0)
         printf("%d\n",len/(len-nextt[len]));
        else
            printf("1\n");
    }
    return 0;
}

 

 

 
 

转载于:https://www.cnblogs.com/Vampire6/p/11360900.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值