HDU1021---Fibonacci Again

 

http://acm.hdu.edu.cn/showproblem.php?pid=1021

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 58897    Accepted Submission(s): 27542


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

 

Output
Print the word "yes" if 3 divide evenly into F(n).  ??      3均匀的将F(n)分割??

Print the word "no" if not.
 

 

Sample Input
0 1 2 3 4 5
 

 

Sample Output
no no yes no no no
一脸懵逼。。此题啥意思??
 
由同余式的基本性质:
(1)自反性:a = a( mod m)。
以及同余式的四则运算法则:
(1)如果 a =b( mod m)且 c = d( mod m),则 a +c = (b + d)( mod m)。
可知,F(n) = F(n) ( mod m) = ( F(n-1) +F(n-2) )( mod m)。
 
根据题目已知条件:
Print the word”yes” if 3 divide evenly into F(n);Print the word”no” if not.
这里m取值为3,则可将公式条件演变为:
综上所述,可得到以下对应关系:F(0)= 1, F(1) = 2, F(n) = ( F(n-1) + F(n-2)  )( mod 3) (n>=2).
index  0  1  2  3  4  5  6  7  8  9  10  11  12  13
value  1  2  0  2  2  1  0  1  1  2   0   2   2  1
print  no no yes no  no no yes  no  no  no  yes  no  no  no
这样我们就得到了如下 规律:从第2个开始每隔4个循环一次。
 
 
#include "iostream"
#include "cstdio"
using namespace std;

int main()
{
    int n;
    while(scanf("%d", &n) !=EOF)
    {
        if((n-2)%4!=0)
           printf("no\n");
        else
           printf("yes\n");
    }
return 0;
}

 

转载于:https://www.cnblogs.com/kimsimple/p/6517542.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值