Euclid's Game

Starts with two unequal positive numbers (M,N and M>N) on the board. Two players move in turn. On each move, a player has to write on the board a positive number equal to the difference of two numbers already on the board; this number must be new, i.e., different from all the numbers already on the board. The player who cannot move loses the game. Should you choose to move first or second in this game?

According to the above rules, there are two players play tihs game. Assumptions A write a number on the board at first, then B write it.

Your task is write a program to judge the winner is A or B.

Input

Two unequal positive numbers M and N , M>N (M<1000000)

Output

A or B

Sample Input

3 1

Sample Output

A



#include<stdio.h>
int gcd(long a,long b)
{
return b==0?a:gcd(b,a%b);
}
void main()
{
long m,n;
scanf("%d %d",&m,&n);
m=m/gcd(m,n);
if(m%2)printf("A\n");
else printf("B\n");
}

转载于:https://www.cnblogs.com/zhang20115330/p/3202210.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值