AtCoder Beginner Contest 088 C Takahashi's Information

Problem Statement

We have a 3×3 grid. A number ci,j is written in the square (i,j), where (i,j) denotes the square at the i-th row from the top and the j-th column from the left.
According to Takahashi, there are six integers a1,a2,a3,b1,b2,b3 whose values are fixed, and the number written in the square (i,j) is equal to ai+bj.
Determine if he is correct.

Constraints
  • ci,j (1≤i≤3,1≤j≤3) is an integer between 0 and 100 (inclusive).
Input

Input is given from Standard Input in the following format:

c1,1 c1,2 c1,3
c2,1 c2,2 c2,3
c3,1 c3,2 c3,3
Output

If Takahashi's statement is correct, print Yes; otherwise, print No.

Sample Input 1
1 0 1
2 1 2
1 0 1
Sample Output 1
Yes

Takahashi is correct, since there are possible sets of integers such as: a1=0,a2=1,a3=0,b1=1,b2=0,b3=1.

Sample Input 2
2 2 2
2 1 2
2 2 2
Sample Output 2
No

Takahashi is incorrect in this case.

Sample Input 3
0 8 8
0 8 8
0 8 8
Sample Output 3
Yes
Sample Input 4
1 8 6
2 9 7
0 7 7
Sample Output 4
No

枚举。
代码:
#include <bits/stdc++.h>
using namespace std;
int s[3][3];
int check()
{
    if(s[0][1] - s[0][0] != s[1][1] - s[1][0] || s[0][1] - s[0][0] != s[2][1] - s[2][0])return 0;
    if(s[0][2] - s[0][0] != s[1][2] - s[1][0] || s[0][2] - s[0][0] != s[2][2] - s[2][0])return 0;
    if(s[0][1] - s[0][2] != s[1][1] - s[1][2] || s[0][1] - s[0][2] != s[2][1] - s[2][2])return 0;
    if(s[0][0] - s[1][0] != s[0][1] - s[1][1] || s[0][0] - s[1][0] != s[0][2] - s[1][2])return 0;
    if(s[0][0] - s[2][0] != s[0][1] - s[2][1] || s[0][0] - s[2][0] != s[0][2] - s[2][2])return 0;
    if(s[2][0] - s[1][0] != s[2][1] - s[1][1] || s[2][0] - s[1][0] != s[2][2] - s[1][2])return 0;
    return 1;
}
int main()
{
    for(int i = 0;i < 3;i ++)
    {
        for(int j = 0;j < 3;j ++)
        {
            cin>>s[i][j];
        }
    }
    if(check())cout<<"Yes";
    else cout<<"No";
}

 

转载于:https://www.cnblogs.com/8023spz/p/8551938.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值