UVA 315 求割点 模板 Tarjan

D - D
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Download as PDF
 

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N. No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

 

Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0.

 

Output

The output contains for each block except the last in the input file one line containing the number of critical places.

 

Sample Input

 

5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0

 

Sample Output

 

1
2
题意:
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <cstring>
#include <string>
#include <algorithm>
using namespace std;
typedef long long ll;
#define MM(a,b) memset(a,b,sizeof(a));
#define inf 0x7f7f7f7f
#define FOR(i,n) for(int i=1;i<=n;i++)
#define CT continue;
#define PF printf
#define SC scanf

vector<int> G[105];
int ans=0,pre[105],low[105],dfs_clock,mp[105][105];

void Trajan(int u,int par)
{
    pre[u]=low[u]=++dfs_clock;
    int child=0,iscut=0;
    for(int i=0;i<G[u].size();i++){
        int v=G[u][i];
        if(!pre[v]){
           child++;
           Trajan(v,u);
           low[u]=min(low[u],low[v]);
           if(low[v]>=pre[u]) iscut=1;
        }
        else if(v!=par) low[u]=min(low[u],pre[v]);//反向边更新,模拟训练指南313页上图
    }
    if(child==1&&par==-1) iscut=0;//删除顶点
    if(iscut) ans++;
}

int main()
{
    int n,u;
    while(~scanf("%d",&n)&&n)
    {
        MM(mp,0);
        FOR(i,n) G[i].clear();
        while(~scanf("%d",&u)&&u){
            while(1){
            int v;char c;
            SC("%d%c",&v,&c);
            mp[u][v]=mp[v][u]=1;
            if(c=='\n') break;
            }
        }
        FOR(i,n) for(int j=i+1;j<=n;j++) if(mp[i][j]) {
            G[i].push_back(j);
            G[j].push_back(i);
        }

        MM(pre,0);
        MM(low,0);
        ans=dfs_clock=0;
        FOR(i,n) if(!pre[i]) Trajan(i,-1);//发现新的联通块
        PF("%d\n",ans);
    }
    return 0;
}

  

 

转载于:https://www.cnblogs.com/smilesundream/p/5705657.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值