ACM dp问题 给房子涂色

Description

The people of Mohammadpur have decided to paint each of their houses red, green, or blue. They've also decided that no two neighboring houses will be painted the same color. The neighbors of house i are houses i-1 and i+1. The first and last houses are not neighbors.

You will be given the information of houses. Each house will contain three integers "R G B" (quotes for clarity only), where R, G and Bare the costs of painting the corresponding house red, green, and blue, respectively. Return the minimal total cost required to perform the work.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case begins with a blank line and an integer n (1 ≤ n ≤ 20) denoting the number of houses. Each of the next n lines will contain 3 integers "R G B". These integers will lie in the range [1, 1000].

Output

For each case of input you have to print the case number and the minimal cost.

Sample Input

2

 

4

13 23 12

77 36 64

44 89 76

31 78 45

 

3

26 40 83

49 60 57

13 89 99

Sample Output

Case 1: 137

Case 2: 96

Hint

Use simple DP

 

  解题思路:

题目的大意是有n户人,打算把他们的房子图上颜色,有red、green、blue三种颜色,每家人涂不同的颜色要花不同的费用,而且相邻两户人家之间的颜色要不同,求最小的总花费费用。这是一个动态规划的题目,和数字三角形有些相似,dp[i][j]是指第i个房子选用第j种方案的钱数。注意要使相邻两户人家之间的颜色要不同。

程序代码:

#include <iostream>
#include <cstring>
using namespace std;
int a[25][3],dp[25][3];
int min(int x,int y)
{
	return x<y?x:y;
}
int main()
{
	int t,k=0;
	cin>>t;
	while(t--)
	{
		int n;
		cin>>n;
		for(int u=0;u<n;u++)
			cin>>a[u][0]>>a[u][1]>>a[u][2];
		memset(dp,0,sizeof(dp));
		for(int v=0;v<3;v++)
			dp[0][v]=a[0][v];
		for(int i=1;i<n;i++)
			for(int j=0;j<3;j++)
				dp[i][j]=dp[i][j]+min(dp[i-1][(j+1)%3],dp[i-1][(j+2)%3])+a[i][j];
		int sum;
		sum=min(dp[n-1][0],min(dp[n-1][1],dp[n-1][2]));
	    cout<<"Case "<<++k<<": "<<sum<<endl;
	}
	return 0;
}

 

  

 

转载于:https://www.cnblogs.com/xinxiangqing/p/4732646.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值