HDU 4022 Bombing(基本算法-水题)

Bombing


Problem Description
It’s a cruel war which killed millions of people and ruined series of cities. In order to stop it, let’s bomb the opponent’s base.
It seems not to be a hard work in circumstances of street battles, however, you’ll be encountered a much more difficult instance: recounting exploits of the military. In the bombing action, the commander will dispatch a group of bombers with weapons having the huge destructive power to destroy all the targets in a line. Thanks to the outstanding work of our spy, the positions of all opponents’ bases had been detected and marked on the map, consequently, the bombing plan will be sent to you.
Specifically, the map is expressed as a 2D-plane with some positions of enemy’s bases marked on. The bombers are dispatched orderly and each of them will bomb a vertical or horizontal line on the map. Then your commanded wants you to report that how many bases will be destroyed by each bomber. Notice that a ruined base will not be taken into account when calculating the exploits of later bombers.
 

Input
Multiple test cases and each test cases starts with two non-negative integer N (N<=100,000) and M (M<=100,000) denoting the number of target bases and the number of scheduled bombers respectively. In the following N line, there is a pair of integers x and y separated by single space indicating the coordinate of position of each opponent’s base. The following M lines describe the bombers, each of them contains two integers c and d where c is 0 or 1 and d is an integer with absolute value no more than 10 9, if c = 0, then this bomber will bomb the line x = d, otherwise y = d. The input will end when N = M = 0 and the number of test cases is no more than 50.
 

Output
For each test case, output M lines, the ith line contains a single integer denoting the number of bases that were destroyed by the corresponding bomber in the input. Output a blank line after each test case.
 

Sample Input
 
  
3 2 1 2 1 3 2 3 0 1 1 3 0 0
 

Sample Output
 
  
2 1
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   4021  4023  4030  4028  4027 
 

题目大意:

告诉你n个坐标的点,m各操作,每次操作0表示消除所给x坐标对应的与其x相同点,每次操作1消除所给y坐标对应的点,输出每次消除的点数、


解题思路:

map 加 mutiset ,水过。


解题代码:

#include <iostream>
#include <cstdio>
#include <map>
#include <set>
using namespace std;

map <int,multiset<int> > mpx;
map <int,multiset<int> > mpy;
int n,m;

int main(){
    int a,c;
    while(scanf("%d%d",&n,&m)!=EOF && (m||n) ){
        mpx.clear();
        mpy.clear();
        for(int i=0;i<n;i++){
            scanf("%d%d",&a,&c);
            mpx[a].insert(c);
            mpy[c].insert(a);
        }
        for(int i=0;i<m;i++){
            scanf("%d%d",&a,&c);
            if(a==0){
                printf("%d\n",mpx[c].size() );
                for(multiset<int>::iterator it=mpx[c].begin();it!=mpx[c].end();it++){
                    int y=(*it);
                    mpy[y].erase(mpy[y].find(c));
                }
                mpx[c].clear();
            }else{
                printf("%d\n",mpy[c].size() );
                for(multiset<int>::iterator it=mpy[c].begin();it!=mpy[c].end();it++){
                    int x=(*it);
                    mpx[x].erase(mpx[x].find(c));
                }
                mpy[c].clear();
            }
        }
        printf("\n");
    }
    return 0;
}





版权声明:欢迎关注我的博客,本文为博主toyking原创文章,未经博主允许不得转载。

转载于:https://www.cnblogs.com/toyking/p/4951001.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值