POJ 题目3667 Hotel(线段树,区间更新查询,求连续区间)

Hotel
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 13805 Accepted: 5996

Description

The cows are journeying north to Thunder Bay in Canada to gain cultural enrichment and enjoy a vacation on the sunny shores of Lake Superior. Bessie, ever the competent travel agent, has named the Bullmoose Hotel on famed Cumberland Street as their vacation residence. This immense hotel has N (1 ≤ N ≤ 50,000) rooms all located on the same side of an extremely long hallway (all the better to see the lake, of course).

The cows and other visitors arrive in groups of size Di (1 ≤ Di ≤ N) and approach the front desk to check in. Each group i requests a set of Di contiguous rooms from Canmuu, the moose staffing the counter. He assigns them some set of consecutive room numbers r..r+Di-1 if they are available or, if no contiguous set of rooms is available, politely suggests alternate lodging. Canmuu always chooses the value of r to be the smallest possible.

Visitors also depart the hotel from groups of contiguous rooms. Checkout i has the parameters Xi and Di which specify the vacating of rooms Xi ..Xi +Di-1 (1 ≤ XiN-Di+1). Some (or all) of those rooms might be empty before the checkout.

Your job is to assist Canmuu by processing M (1 ≤ M < 50,000) checkin/checkout requests. The hotel is initially unoccupied.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Line i+1 contains request expressed as one of two possible formats: (a) Two space separated integers representing a check-in request: 1 and Di (b) Three space-separated integers representing a check-out: 2, Xi, and Di

Output

* Lines 1.....: For each check-in request, output a single line with a single integer r, the first room in the contiguous sequence of rooms to be occupied. If the request cannot be satisfied, output 0.

Sample Input

10 6
1 3
1 3
1 3
1 3
2 5 5
1 6

Sample Output

1
4
7
0
5

Source

USACO 2008 February Gold

题意:有一个线段,从1到n。以下m个操作,操作分两个类型,以1开头的是查询操作,以2开头的是更新操作

1 w  表示在总区间内查询一个长度为w的可用区间,而且要最靠左,能找到的话返回这个区间的左端点并占用了这个区间,找不到返回0 

好像n=10 , 1 3 查到的最左的长度为3的可用区间就是[1,3]。返回1,而且该区间被占用了

2 a len , 表示从单位a開始,清除一段长度为len的区间(将其变为可用。不被占用),不须要输出

ac代码

#include<stdio.h>
#include<string.h>
#define max(a,b) (a>b?a:b)
struct s
{
	int ll,rl,ml,cover;
}node[50050<<2];
void build(int l,int r,int tr)
{
	node[tr].ll=node[tr].rl=node[tr].ml=r-l+1;
	node[tr].cover=-1;
	if(l==r)
		return;
	int mid=(l+r)>>1;
	build(l,mid,tr<<1);
	build(mid+1,r,tr<<1|1);
}
void pushdown(int tr,int m)
{
	if(node[tr].cover!=-1)
	{
		node[tr<<1].cover=node[tr<<1|1].cover=node[tr].cover;
		if(node[tr].cover==0)
		{
			node[tr<<1].ll=node[tr<<1].rl=node[tr<<1].ml=m-(m>>1);
			node[tr<<1|1].ll=node[tr<<1|1].rl=node[tr<<1|1].ml=(m>>1);
		}
		else
		{
			node[tr<<1].ll=node[tr<<1].rl=node[tr<<1].ml=0;
			node[tr<<1|1].ll=node[tr<<1|1].rl=node[tr<<1|1].ml=0;
		}
		node[tr].cover=-1;
	}
}
void pushup(int tr,int m)
{
	node[tr].ll=node[tr<<1].ll;
	node[tr].rl=node[tr<<1|1].rl;
	if(node[tr].ll==m-(m>>1))
		node[tr].ll+=node[tr<<1|1].ll;
	if(node[tr].rl==(m>>1))
		node[tr].rl+=node[tr<<1].rl;
	node[tr].ml=max(node[tr<<1].rl+node[tr<<1|1].ll,max(node[tr<<1].ml,node[tr<<1|1].ml));
}
void update(int L,int R,int l,int r,int tr,int val)
{
	if(L<=l&&R>=r)
	{
		if(val)
		{
			node[tr].ll=node[tr].rl=node[tr].ml=0;
		}
		else
			node[tr].ll=node[tr].rl=node[tr].ml=r-l+1;
		node[tr].cover=val;
		return;
	}
	pushdown(tr,r-l+1);
	int mid=(l+r)>>1;
	if(L>mid)
	{
		update(L,R,mid+1,r,tr<<1|1,val);
	}
	else
		if(R<=mid)
		{
			update(L,R,l,mid,tr<<1,val);
		}
		else
		{
			update(L,mid,l,mid,tr<<1,val);
			update(mid+1,R,mid+1,r,tr<<1|1,val);
		}
	/*if(L<=mid)
		update(L,R,l,mid,tr<<1,val);
	if(R>mid)
		update(L,R,mid+1,r,tr<<1|1,val);*/
	pushup(tr,r-l+1);
}
int query(int w,int l,int r,int tr)
{
	if(l==r)
		return l;
	pushdown(tr,r-l+1);
	int mid=(l+r)>>1;
	if(node[tr<<1].ml>=w)
		return query(w,l,mid,tr<<1);
	else
		if(node[tr<<1].rl+node[tr<<1|1].ll>=w)
			return mid-node[tr<<1].rl+1;
		else
			return query(w,mid+1,r,tr<<1|1);
}
int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		build(1,n,1);
		while(m--)
		{
			int op;
			scanf("%d",&op);
			if(op==1)
			{
				int a;
				scanf("%d",&a);
				if(a>node[1].ml)
				{
					printf("0\n");
					continue;
				}
				int p=query(a,1,n,1);
				printf("%d\n",p);
				update(p,p+a-1,1,n,1,1);
			}
			else
			{
				int a,b;
				scanf("%d%D",&a,&b);
				update(a,a+b-1,1,n,1,0);
			}
		}
	}
}


转载于:https://www.cnblogs.com/llguanli/p/6920163.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值