hdu 1002大数(Java)

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 230395    Accepted Submission(s): 44208


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 
 
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 
 
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 
 
 
Sample Input
2 1 2 112233445566778899 998877665544332211
 
 
 
Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110


链接: http://acm.hdu.edu.cn/showproblem.php?pid=1002


题意:就是简单的A+B,就只要注意最后一组数据后没多余的空行就ok了,用c/c++比较麻烦,用java轻而易举就搞定了,so~,c的代码就不贴了。



 1 import java.util.*;
 2  2 import java.math.*;
 3  3 public class Main {
 4  4     public static void main(String[] args) {
 5  5         int T;
 6  6         BigDecimal a,b,c;             //定义两个大数型变量a,b
 7  7         Scanner cin = new Scanner(System.in);    
 8  8         T = cin.nextInt();
 9  9         for (int i=1; i<=T; i++){
10 10             a = cin.nextBigDecimal();
11 11             b = cin.nextBigDecimal();
12 12             //c = a.add(b);        //java的加法和c/c++的不同,四则运算都要写成这种形式
13 13             System.out.println("Case "+i+":");
14 14             System.out.println(a+" + "+b+" = "+(a.add(b)));
15 15             if (i != T)        //最后一组数据后没有多余的空行。
16 16             System.out.println();
17 17         }
18 18 
19 19     }
20 20 }
View Code

 

转载于:https://www.cnblogs.com/dxd-success/p/4168032.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值