poj 1270 Following Orders (拓扑排序+回溯)

 

Following Orders
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 5473 Accepted: 2239

Description

Order is an important concept in mathematics and in computer science. For example, Zorn's Lemma states: ``a partially ordered set in which every chain has an upper bound contains a maximal element.'' Order is also important in reasoning about the fix-point semantics of programs. 


This problem involves neither Zorn's Lemma nor fix-point semantics, but does involve order. 
Given a list of variable constraints of the form x < y, you are to write a program that prints all orderings of the variables that are consistent with the constraints. 


For example, given the constraints x < y and x < z there are two orderings of the variables x, y, and z that are consistent with these constraints: x y z and x z y. 

Input

The input consists of a sequence of constraint specifications. A specification consists of two lines: a list of variables on one line followed by a list of contraints on the next line. A constraint is given by a pair of variables, where x y indicates that x < y. 


All variables are single character, lower-case letters. There will be at least two variables, and no more than 20 variables in a specification. There will be at least one constraint, and no more than 50 constraints in a specification. There will be at least one, and no more than 300 orderings consistent with the contraints in a specification. 


Input is terminated by end-of-file. 

Output

For each constraint specification, all orderings consistent with the constraints should be printed. Orderings are printed in lexicographical (alphabetical) order, one per line. 


Output for different constraint specifications is separated by a blank line. 

Sample Input

a b f g
a b b f
v w x y z
v y x v z v w v

Sample Output

abfg
abgf
agbf
gabf

wxzvy
wzxvy
xwzvy
xzwvy
zwxvy
zxwvy

题目大意:

给你一个有向无环图,请你按字典序输出它所有的toposort结果。

 

回溯法。

回溯时如果使用了全局变量,要在递归出口处立即还原该全局变量,如ac代码中的vis数组和path数组。

此题输入输出好坑啊。用gets才行,I also not kow why。

 

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
#include<stack>
typedef long long ll;
const int maxn=10000;

char str1[100],str2[300];
int exis[26];//26个lowercase字母
int tot;//一共存在多少字母
int cnt;
int to[100];
int next[100];
int head[26];
int in[26];//入度
int vis[26];
char path[30];

void dfs(int x,int m)
{
    if(m==tot-1)
        printf("%s\n",path);
    for(int i=head[x];i!=-1;i=next[i])
    {
        int l=to[i];
        if(!vis[l])
            in[l]--;
    }
    for(int i=0;i<26;i++)
    {
        if(!vis[i]&&exis[i]&&in[i]==0)
        {
            vis[i]=1;
            path[m+1]='a'+i;
            dfs(i,m+1);
            path[m+1]='\0';
            vis[i]=0;
        }
    }
    for(int i=head[x];i!=-1;i=next[i])
    {
        int l=to[i];
        if(!vis[l])
            in[l]++;
    }
}

int main()
{
    int k=0;
    while(gets(str1))
    {
        gets(str2);
        if(k>0)
            printf("\n");
        k++;

        memset(exis,0,sizeof(exis));
        tot=0;
        for(int i=0;str1[i]!='\0';i++)
        {
            if(str1[i]>='a'&&str1[i]<='z')
            {
                exis[str1[i]-'a']=1;
                tot++;
            }
        }
        cnt=0;
        memset(head,-1,sizeof(head));
        memset(in,0,sizeof(in));
        for(int i=0;str2[i]!='\0';i+=4)
        {
            int u=str2[i]-'a',v=str2[i+2]-'a';
            to[cnt]=v;next[cnt]=head[u];head[u]=cnt++;
            in[v]++;
        }

        memset(vis,0,sizeof(vis));
        for(int i=0;i<30;i++)
            path[i]='\0';
        for(int i=0;i<26;i++)
        {
            if(exis[i]&&in[i]==0)
            {
                vis[i]=1;
                path[0]='a'+i;
                dfs(i,0);
                path[0]='\0';
                vis[i]=0;
            }
        }
    }
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/acboyty/p/9974644.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值