poj 2184 Cow Exhibition

Cow Exhibition
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15034 Accepted: 6098

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS: 

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF 
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value 
of TS+TF to 10, but the new value of TF would be negative, so it is not 
allowed. 

Source

题意:有n头牛,每头牛有一个s值和一个F值,从这n头牛中选取几头牛,使得其s值与F值的和的最大值,求这个最大值,并且要求s与F值的总和都分别大于0.
思路:01背包,可以把其中一个指标,譬如s值,当作背包重量,另一个值当作价值即可。因为重量涉及到负数,所以为了让所有重量值都为整数,可以整体增加一个基值进行平移。
AC代码:
#define _CRT_SECURE_NO_DEPRECATE
#include<iostream>
#include<vector>
#include<map>
#include<string>
#include<algorithm>
using namespace std;
#define N_MAX 101
#define INF 0x3f3f3f3f
int dp[N_MAX*1000*2+20];
int s[N_MAX],t[N_MAX],n;
int main() {
    while (scanf("%d",&n)!=EOF) {
        for (int i = 0; i < n; i++) {
            scanf("%d%d",&s[i],&t[i]);
       }
        int center = n * 1000;
        int range = 2 * center + 10;
        fill(dp, dp + range, -INF);
        dp[center] = 0;
        for (int i = 0; i < n;i++) {
            if (s[i] >= 0) {
                for (int j = range; j >= s[i]; j--) {
                    dp[j] = max(dp[j],dp[j-s[i]]+t[i]);
              }
            }
            else {
                for (int j = s[i]; j - s[i] < range;j++) {
                    dp[j] = max(dp[j],dp[j-s[i]]+t[i]);
                }
            }
        }
        int max_sum = -INF;
        for (int i = center; i <range;i++) {
            if (dp[i] >= 0) {
                max_sum = max(max_sum, i-center+dp[i]);
            }
        }
        if (max_sum < 0)puts("0");
        else printf("%d\n",max_sum);
    }
    return 0;

}

 

 

转载于:https://www.cnblogs.com/ZefengYao/p/8904034.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值