HDU 1022 Train Problem I

Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.

 

Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.

 

Output
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.

 

Sample Input
 
  
3 123 321 3 123 312

 

Sample Output
 
  
Yes. in in in out out out FINISH No. FINISH
Hint
Hint
For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".

 

Author
Ignatius.L
呢派比较堕落…………成日刷水题,主要系记录得太多,想清清。
尼条绝对就系一条关于堆栈既基本题目啦,就系比入栈顺序你,判断出栈顺序可能否, 我既思路就系直接模拟, 因为数据最大9。
直接贴代码都得啦: 得意
#include <iostream>
#include <vector>
#include <string>
using namespace std;
string o1,o2;
vector<char> tra,sta;
bool sim()
{
	int i=0,j=0;
	tra.clear();
	sta.clear();
	while(i<o1.length()||j<o2.length())
	{
		while(!tra.empty()&&tra[tra.size()-1]==o2[j])
		{
			tra.pop_back();//删除一个元素
			sta.push_back(1);//出栈指令
			j++;//记录出栈的个数
		}
		if(i<o1.length())
		{
			tra.push_back(o1[i++]);//当栈是空的时候,入栈
			sta.push_back(0);//0是入栈指令
		}
		else 
			break;
	}
	if(j==o2.length())
		return 1;
	else 
		return 0;
}
int main()
{
	int n;
	while(cin>>n>>o1>>o2)
	{
		if(sim())
		{
			puts("Yes.");
			for(n=0;
			n<sta.size();n++)
				if(sta[n])
					puts("out");
		}
		else
			puts("No.");
		printf("FINISH\n");
	}
	return 0;
}





转载于:https://www.cnblogs.com/u013533289/p/4477291.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值