4 Values whose Sum is 0
Time Limit: 15000MS | Memory Limit: 228000K | |
Total Submissions: 10535 | Accepted: 2904 | |
Case Time Limit: 5000MS |
Description
The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .
Input
The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2
28 ) that belong respectively to A, B, C and D .
Output
For each input file, your program has to write the number quadruplets whose sum is zero.
Sample Input
6 -45 22 42 -16 -41 -27 56 30 -36 53 -37 77 -36 30 -75 -46 26 -38 -10 62 -32 -54 -6 45
Sample Output
5
Hint
Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).
#include <stdio.h>
#include <algorithm>
using namespace std;
const int N=4000;
int a[N],b[N],c[N],d[N],ab[N*N],cd[N*N];
int main()
{
int n,pab,pcd,ans,i,j,k;
while(scanf("%d",&n)!=EOF)
{
pab=pcd=ans=0;
for(i=0;i<n;i++)
scanf("%d %d %d %d",&a[i],&b[i],&c[i],&d[i]);
for(i=0;i<n;i++)
for(j=0;j<n;j++)
{
ab[pab++]=a[i]+b[j];
cd[pcd++]=-c[i]-d[j];
}
sort(cd,cd+pcd);
for(i=0;i<pab;i++)
{
int l=0,r=pcd-1,mid;
while(l<=r)
{
mid=(l+r)/2;
if(ab[i]==cd[mid])
{
ans++;
for(k=mid+1;k<pcd;k++)
if(ab[i]==cd[k])
ans++;
else break;
for(k=mid-1;k>=0;k--)
if(ab[i]==cd[k])
ans++;
else break;
break;
}
else if(ab[i]<cd[mid])
r=mid-1;
else l=mid+1;
}
}
printf("%d\n",ans);
}
}