hdu 5945 Fxx and game 单调队列优化dp

Fxx and game

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)



Problem Description
Young theoretical computer scientist Fxx designed a game for his students.

In each game, you will get three integers  X,k,t.In each step, you can only do one of the following moves:

1.X=Xi(0<=i<=t).

2.if k|X,X=X/k.

Now Fxx wants you to tell him the minimum steps to make X become 1.
 

 

Input
In the first line, there is an integer  T(1T20) indicating the number of test cases.

As for the following T lines, each line contains three integers X,k,t(0t106,1X,k106)

For each text case,we assure that it's possible to make X become 1。
 

 

Output
For each test case, output the answer.
 

 

Sample Input
2 9 2 1 11 3 3
 

 

Sample Output
4 3
 

 

Source
#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<iostream>
#include<cstdio>
#include<cmath>
#include<string>
#include<queue>
#include<algorithm>
#include<stack>
#include<cstring>
#include<vector>
#include<list>
#include<set>
#include<map>
using namespace std;
#define ll long long
#define pi (4*atan(1.0))
#define eps 1e-14
#define bug(x)  cout<<"bug"<<x<<endl;
const int N=1e6+10,M=1e6+10,inf=2e9;
const ll INF=1e18+10,mod=2147493647;
int dp[N];
int q[N];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        memset(dp,0,sizeof(dp));
        int n,k,t;
        scanf("%d%d%d",&n,&k,&t);
        int l=1,r=1;
        dp[1]=0;
        q[r++]=1;
        for(int i=2;i<=n;i++)
        {
            dp[i]=inf;
            while(l<r&&q[l]<i-t)l++;
            if(l<r)dp[i]=dp[q[l]]+1;
            if(i%k==0)dp[i]=min(dp[i/k]+1,dp[i]);
            while(l<r&&dp[q[r-1]]>=dp[i])r--;
            q[r++]=i;
        }
        //for(int i=1;i<=n;i++)
         //   printf("%d ",dp[i]);
        //printf("\n");
        printf("%d\n",dp[n]);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/jhz033/p/6492535.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值