Graveyard(poj3154)

Graveyard

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 1289 Accepted: 660 Special Judge

Description

Programming contests became so popular in the year 2397 that the governor of New Earck — the largest human-inhabited planet of the galaxy — opened a special Alley of Contestant Memories (ACM) at the local graveyard. The ACM encircles a green park, and holds the holographic statues of famous contestants placed equidistantly along the park perimeter. The alley has to be renewed from time to time when a new group of memorials arrives.

When new memorials are added, the exact place for each can be selected arbitrarily along the ACM, but the equidistant disposition must be maintained by moving some of the old statues along the alley.

Surprisingly, humans are still quite superstitious in 24th century: the graveyard keepers believe the holograms are holding dead people souls, and thus always try to renew the ACM with minimal possible movements of existing statues (besides, the holographic equipment is very heavy). Statues are moved along the park perimeter. Your work is to find a renewal plan which minimizes the sum of travel distances of all statues. Installation of a new hologram adds no distance penalty, so choose the places for newcomers wisely!

Input

Input file contains two integer numbers: n — the number of holographic statues initially located at the ACM, and m — the number of statues to be added (2 ≤ n ≤ 1000, 1 ≤ m ≤ 1000). The length of the alley along the park perimeter is exactly 10 000 feet.

Output

Write a single real number to the output file — the minimal sum of travel distances of all statues (in feet). The answer must be precise to at least 4 digits after decimal point.

Sample Input

2 1
2 3
3 1
10 10

Sample Output

1666.6667
1000.0000
1666.6667
0.0000

Hint

Pictures show the first three examples. Marked circles denote original statues, empty circles denote new equidistant places, arrows denote movement plans for existing statues.

ps:http://poj.org/problem?id=3154

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;

double nmin(double x,double y)
{
    return x<y?x:y;
}
int main()
{
    int n,m,i,j;
    double ans,s,o,temp;
    double a[1005],c[2005];
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        s=1.0/(double)n;
        o=1.0/(double)(n+m);
        for(i=0;i<n;i++)
            a[i]=i*s;
        for(j=0;j<m+n;j++)
            c[j]=j*o;
        ans=0;
        for(i=0;i<n;i++)
        {
            for(j=0;j<m+n;j++)
            {
                if(a[i]<=c[j])
                break;
            }
            int loc=j;
            temp=fabs(a[i]-c[j]);
 //           printf("temp = %lf\n",temp);
            if(loc>0)
                temp=nmin(temp,fabs(a[i]-c[loc-1]));
            if(loc<n+m-1)
                temp=nmin(temp,fabs(a[i]-c[loc+1]));
            ans+=temp;
        }

        printf("%.4f\n",ans*10000);
    }
    return 0;
}

然后下面是大神的代码:

#include<cstdio>
#include<cmath>
using namespace std;

int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)==2)
    {
        double ans=0;
        for(int i=1;i<n;i++)
        {
            double pos=(double)i/n*(n+m);           //计算每个需要移动是雕塑的坐标
            ans+=fabs(pos-floor(pos+0.5))/(n+m);    //累加移动距离
        }
        printf("%.4f\n",ans*10000);//等比例扩大坐标
        //第一次交是lf。。。结果就错了,可能是精度问题吧。
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/yuyixingkong/p/3868580.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值