HDU 1299Diophantus of Alexandria

Diophantus of Alexandria

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3210    Accepted Submission(s): 1269


Problem Description
Diophantus of Alexandria was an egypt mathematician living in Alexandria. He was one of the first mathematicians to study equations where variables were restricted to integral values. In honor of him, these equations are commonly called diophantine equations. One of the most famous diophantine equation is x^n + y^n = z^n. Fermat suggested that for n > 2, there are no solutions with positive integral values for x, y and z. A proof of this theorem (called Fermat's last theorem) was found only recently by Andrew Wiles.

Consider the following diophantine equation: 

1 / x + 1 / y = 1 / n where x, y, n ∈ N+ (1)


Diophantus is interested in the following question: for a given n, how many distinct solutions (i. e., solutions satisfying x ≤ y) does equation (1) have? For example, for n = 4, there are exactly three distinct solutions: 

1 / 5 + 1 / 20 = 1 / 4
1 / 6 + 1 / 12 = 1 / 4
1 / 8 + 1 / 8 = 1 / 4



Clearly, enumerating these solutions can become tedious for bigger values of n. Can you help Diophantus compute the number of distinct solutions for big values of n quickly?
 

 

Input
The first line contains the number of scenarios. Each scenario consists of one line containing a single number n (1 ≤ n ≤ 10^9). 
 

 

Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Next, print a single line with the number of distinct solutions of equation (1) for the given value of n. Terminate each scenario with a blank line. 
 

 

Sample Input
2 4 1260
 

 

Sample Output
Scenario #1: 3
Scenario #2: 113

 

以前留下来的题目,今天才补。

题目大意就是给定n求有多少种x,y的组合 使得1/x+1/y=1/n;

因为x,y都大于n,这样我们可以设y=x+k 那么上边的等式可以化成x=n*n/k+n;

问题变成求有多少种x了,x是整数,多疑k要是n*n的因子才行.

由于任意一个数都可以表示成 n=p1^r1*p2^r2*p3^r3.....pi^ri 这种形式(其中pi是素数),那么因子的数量就是(r1+1)*(r2+1)*(r3+1)....*(ri+1).(因为每种pi可以选择ri个嘛也可以不选)

那么 n*n的因子数呢?  同理可得n*n的因子数为(2*r1+1)*(2*r2+1)*(2*r3+1)....*(2*ri+1)个

/* ***********************************************
Author        :guanjun
Created Time  :2016/10/9 18:38:22
File Name     :hdu1299.cpp
************************************************ */
#include <bits/stdc++.h>
#define ull unsigned long long
#define ll long long
#define mod 90001
#define INF 0x3f3f3f3f
#define maxn 10010
#define cle(a) memset(a,0,sizeof(a))
const ull inf = 1LL << 61;
const double eps=1e-5;
using namespace std;
priority_queue<int,vector<int>,greater<int> >pq;
struct Node{
    int x,y;
};
struct cmp{
    bool operator()(Node a,Node b){
        if(a.x==b.x) return a.y> b.y;
        return a.x>b.x;
    }
};

bool cmp(int a,int b){
    return a>b;
}
int n;
int prime[100000];
int vis[100000];
int num;
void init(){
    num=0;
    memset(vis,0,sizeof vis);
    int x=sqrt(1000000000)+1;
    for(int i=2;i<=x;i++){
        if(!vis[i]){
            prime[++num]=i;
            for(int j=i;j<=x;j+=i)vis[j]=1;
        }
    }
}
int main()
{
    #ifndef ONLINE_JUDGE
    //freopen("in.txt","r",stdin);
    #endif
    //freopen("out.txt","w",stdout);
    init();
    int t;
    cin>>t;
    for(int k=1;k<=t;k++){
        scanf("%d",&n);
        ll ans=1;
        int p,cnt;
        for(int i=1;i<=num;i++){
            p=prime[i];
            cnt=0;
            if(p*p>n)break;
            while(n%p==0){
                cnt++;
                n/=p;
            }
            ans*=(2*cnt+1);
        }
        if(n>1)ans*=3;
        printf("Scenario #%d:\n",k);
        printf("%lld\n\n",(ans+1)/2);
    }
    return 0;
}

真是醉了,筛素数的时候,x=100000和10000是  num会出现诡异的变化....科学事故啊

 

转载于:https://www.cnblogs.com/pk28/p/5943766.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值