算法训练题

从原点出发,一步只能向右走、向上走或向左走。恰好走N步且不经过已走的点共有多少种走法?
样例输入:N=2
样例输出:result=7
样例输入:N=3
样例输出:result=17 
 
代码:

import java.util.Scanner;

public class Foot {
  static int t = 0;
  public static void main(String[] args) {
    int n=new Scanner(System.in).nextInt();

    int[][] a = new int[n+1][2*n+1];
    int x = n;
    int y = n;
    a[x][y] = 1;

    xunhuan(a,n,x,y);
    System.out.println(t);
  }

  private static void xunhuan(int[][] a, int n, int x, int y) {

    if(n!=0){
      if(a[x-1][y] != 1){
        a[x-1][y] = 1;
        xunhuan(a,n-1,x-1,y);
        a[x-1][y] = 0;
      }


      if (a[x][y+1] != 1) {
        a[x][y+1] = 1;
        xunhuan(a,n-1,x,y+1);
        a[x][y+1] = 0;
      }


      if (a[x][y-1] != 1) {
        a[x][y-1] = 1;
        xunhuan(a,n-1,x,y-1);
        a[x][y-1] = 0;
      }

    }else{
      t++;
      for (int i = 0; i < a.length; i++) {
        for (int j = 0; j < a[i].length; j++) {
          System.out.print(a[i][j]);
        }
        System.out.println();
      }
      System.out.println();
    }
  }
}

转载于:https://www.cnblogs.com/-rainbow-/p/7410801.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值