HDOJ 1303 Doubles(简单题)

Problem Description
As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list
1 4 3 2 9 7 18 22

your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.

Input
The input file will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.

Output
The output will consist of one line per input list, containing a count of the items that are double some other item.

Sample Input
1 4 3 2 9 7 18 22 0
2 4 8 10 0
7 5 11 13 1 3 0
-1

Sample Output
3
2
0

题意:就是判断输入的一行数中,有多少对数字相差2倍。
输入的数据不会有重复的。

import java.util.Scanner;

public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            String strNum = sc.nextLine();
            String[] strsNum = strNum.split(" ");
            int[] num = new int[strsNum.length];
            for(int i=0;i<strsNum.length;i++){
                num[i] = Integer.parseInt(strsNum[i]);
            }
            if(num[0]==-1){
                return ;
            }

            int t=0;
            for(int i=0;i<num.length;i++){
                for(int j=0;j<num.length;j++){
                    if(i!=j){
                        //注意除数不能为0!
                        if(num[j]!=0){
                            double two = (num[i]*1.0)/(1.0*num[j]);
                            if(two==2){
                                t++;
                                break;
                            }
                        }
                    }
                }
            }
            System.out.println(t);
        }
    }

}

转载于:https://www.cnblogs.com/webmen/p/5739316.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值