poj1562 Oil Deposits 深搜模板题

题目描述:

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2



题意:
判断在一个图形中‘@’连通的有几块。

题解:
典型的dfs模板题,套用模板即可。并记得将搜索过的’@‘转换成’*‘


代码:
#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;
char a[105][105];
int n,m,i,j;

void dfs(int x,int y)
{
    a[x][y]='*';
    for(int dx=-1;dx<=1;dx++)    //以一个点为中心,判断他周围有无‘@’,一直搜索下去,直到没有相连通的‘@’
    for(int dy=-1;dy<=1;dy++){
        int nx=dx+x;
        int ny=dy+y;
        if(nx>=0&&nx<n&&ny>=0&&ny<m&&a[nx][ny]=='@') dfs(nx,ny);
    }
    return ;
}

void solve()
{
    int ans=0;
    for(i=0;i<n;i++)
    for(j=0;j<m;j++){
        if(a[i][j]=='@')
        {
            dfs(i,j);
            ans++;            //每遇到一个‘@’,就将连通快总数加1,并通过dfs把相连通的‘@’都转化成‘*’
        }
    }
    printf("%d\n",ans);
}

int main()
{
    while(1){
        scanf("%d%d",&n,&m);
        if(n==0&&m==0) break;
        memset(a,0,sizeof(a));
        for(i=0;i<n;i++){
            scanf("%s",a[i]);     //输入的时候要注意,如果输入%c,记得加getchar();
        }
        solve();
    }
    return 0;
}

 








转载于:https://www.cnblogs.com/y1040511302/p/9630032.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值