POJ 3080 Blue Jeans(KMP模式匹配)

Blue Jeans

Time Limit: 1000MS

 

Memory Limit: 65536K

Total Submissions: 7333

 

Accepted: 3048

Description

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated. 

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers. 

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC. 

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:

  • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
  • m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.

Sample Input

3

2

GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA

AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA

3

GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA

GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA

GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA

3

CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC

ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA

AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output

no significant commonalities

AGATAC

CATCATCAT

Source

South Central USA 2006

 解题报告:这道题是典型的串的模式匹配,但这个题是多组,求出最长的公共子串,若公共子串的长度相同时,按字典序输出第一个,这道题得利用KMP算法,虽然学过但是现在已经忘了,哎!昨天做的时候套用的模板,看了一下网上的解题报告,AC了,但是今天重新敲了一边,WA了好几次才提交上,

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
using namespace std;
const int N = 65;
char DNA[10][N], s[N];
int n, m, next[N], flag, ans, maxa;
void get_next()
{
int i= 0, j = -1;
int len = strlen(s);
next[0] = -1;
while (i < len)
{
if (j == -1 || s[i] == s[j])
{
++ i;
++ j;
next[i] = j;
}
else
{
j = next[j];
}
}
}
void KMP()
{
int k, i, j, len, p;
get_next();
len = strlen(s);
maxa = 100;
for (k = 1; k < n; ++k)
{
i = 0;
j = 0;
p = 0;
while (i < 60 && j < len)
{
if (j == -1 || DNA[k][i] == s[j])
{
++ i;
++ j;
}
else
{
j = next[j];
}
if (j > p)
{
p = j;
}
}
if (p < maxa)
{
maxa = p;
}
}
}
int main()
{
int t, i;
char str[N];
scanf("%d", &t);
while (t --)
{
scanf("%d", &n);
for (i = 0; i < n; ++i)
{
scanf("%s", DNA[i]);
}
ans = 0;
for (i = 0; i < 58; ++i)
{
//通过枚举第一个字符串所有字符后缀串
strcpy(s, DNA[0] + i);//字符串复制,把DNA[0]从第i + 1个字符到最后复制给s字符串
KMP();
if (ans < maxa)
{
ans = maxa;
strncpy(str, DNA[0] + i, ans);//字符串的复制,把DNA[0]从第i + 1个字符到i+ ans + 1复制给str字符串,就是把ans长度的字符复制给str
str[ans] = '\0';
}
else if (ans == maxa)//若长度相同则存储较小的那个
{
char str1[N];
strncpy(str1, DNA[0] + i, ans);
str1[ans] = '\0';
if (strcmp(str1, str) < 0)
{
strcpy(str, str1);
}
}
}
if (ans >= 3)
{
printf("%s\n", str);
}
else
{
printf("no significant commonalities\n");
}
}
return 0;
}



转载于:https://www.cnblogs.com/lidaojian/archive/2012/03/16/2400856.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值