Codeforces Round #410 (Div. 2)B. Mike and strings(暴力)

传送门

Description

Mike has n strings s1, s2, ..., sn each consisting of lowercase English letters. In one move he can choose a string si, erase the first character and append it to the end of the string. For example, if he has the string "coolmike", in one move he can transform it into the string "oolmikec".

Now Mike asks himself: what is minimal number of moves that he needs to do in order to make all the strings equal?

Input

The first line contains integer n (1 ≤ n ≤ 50) — the number of strings.

This is followed by n lines which contain a string each. The i-th line corresponding to string si. Lengths of strings are equal. Lengths of each string is positive and don't exceed 50.

Output

Print the minimal number of moves Mike needs in order to make all the strings equal or print  - 1 if there is no solution.

Sample Input

4
xzzwo
zwoxz
zzwox
xzzwo
2
molzv
lzvmo

3
kc
kc
kc

3
kc
kc
kc

Sample Output

5

2

0

-1

思路

题解:

数据范围很小,因此直接暴力求解。

 

#include<bits/stdc++.h>
using namespace std;
const int INF = (1<<30)-1;
const int maxn = 55;
char str[maxn][maxn];
char tmp[maxn],tmp1[maxn];

int main()
{
	//freopen("input.txt","r",stdin);
	int n,res = INF;
	bool flag = false,success = true;
	scanf("%d",&n);
	for (int i = 0;i < n;i++)
	{
		scanf("%s",str[i]);
	}
	int len = strlen(str[0]);
	for (int i = 0;i < n;i++)
	{
		int cnt = 0;
		for (int j = 0;j < n;j++)
		{
			if (i == j)
			{
				flag = true;
				continue;
			}
			flag = false;
			if (strcmp(str[j],str[i]) == 0)
			{
				flag = true;
				continue;
			}
			strcpy(tmp1,str[j]);
			int tmplen = len;
			
			while (--tmplen)
			{
				strncpy(tmp,tmp1+1,len-1);
				tmp[len - 1] = tmp1[0];
				cnt++;
				strcpy(tmp1,tmp);
				if (strcmp(tmp1,str[i]) == 0)
				{
					flag = true;
					break;
				}
			}
			if (!flag)	
			{
				success = false;
				break;
			}
		}
		if (!flag)
		{
			success = false; 
			break;
		}
		res = min(res,cnt);
	}
	if (!success)	printf("-1\n");
	else	printf("%d\n",res);
	return 0;
}

  

转载于:https://www.cnblogs.com/ZhaoxiCheung/p/6751758.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值