idea编译工程时出现Error:java: 无效的目标发行版: 1.8?

  idea编译工程时出现Error:java: 无效的目标发行版: 1.8?

       

 

见图,从上述可以看出工程用的jdk1.7,而idea编译时采用的是1.8版本(应该idea新版本内置的jre是1.8吧,默认编译采用1.8)

 

修改:如下图

                

 

如果改完了发现还是不行,那么可以继续下面的步骤:

                 file--> settings--> java complier --- > 找到项目module,修改为1.8 就可以了。

转载于:https://www.cnblogs.com/gcyinsist/p/7670239.html

  • 0
    点赞
  • 0
    评论
  • 0
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

表情包
插入表情
评论将由博主筛选后显示,对所有人可见 | 还能输入1000个字符
相关推荐
©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页