[USACO14DEC] 驮运Piggy Back

题目描述

Bessie and her sister Elsie graze in different fields during the day, and in the evening they both want to walk back to the barn to rest. Being clever bovines, they come up with a plan to minimize the total amount of energy they both spend while walking.

Bessie spends B units of energy when walking from a field to an adjacent field, and Elsie spends E units of energy when she walks to an adjacent field. However, if Bessie and Elsie are together in the same field, Bessie can carry Elsie on her shoulders and both can move to an adjacent field while spending only P units of energy (where P might be considerably less than B+E, the amount Bessie and Elsie would have spent individually walking to the adjacent field). If P is very small, the most energy-efficient solution may involve Bessie and Elsie traveling to a common meeting field, then traveling together piggyback for the rest of the journey to the barn. Of course, if P is large, it may still make the most sense for Bessie and Elsie to travel

separately. On a side note, Bessie and Elsie are both unhappy with the term "piggyback", as they don't see why the pigs on the farm should deserve all the credit for this remarkable form of

transportation.

Given B, E, and P, as well as the layout of the farm, please compute the minimum amount of energy required for Bessie and Elsie to reach the barn.

Bessie 和 Elsie在不同的区域放牧,他们希望花费最小的能量返回谷仓。从一个区域走到一个相连区域,Bessie要花费B单位的能量,Elsie要花费E单位的能量。

如果某次他们两走到同一个区域,Bessie 可以背着 Elsie走路,花费P单位的能量走到另外一个相连的区域。当然,存在P>B+E的情况。

相遇后,他们可以一直背着走,也可以独立分开。

输入输出格式

输入格式:

INPUT: (file piggyback.in)

The first line of input contains the positive integers B, E, P, N, and M. All of these are at most 40,000. B, E, and P are described above. N is the number of fields in the farm (numbered 1..N, where N >= 3), and M is the number of connections between fields. Bessie and Elsie start in fields 1 and 2, respectively. The barn resides in field N.

The next M lines in the input each describe a connection between a pair of different fields, specified by the integer indices of the two fields. Connections are bi-directional. It is always possible to travel from field 1 to field N, and field 2 to field N, along a series of such connections.

输出格式:

OUTPUT: (file piggyback.out)

A single integer specifying the minimum amount of energy Bessie and

Elsie collectively need to spend to reach the barn. In the example

shown here, Bessie travels from 1 to 4 and Elsie travels from 2 to 3

to 4. Then, they travel together from 4 to 7 to 8.

输入输出样例

输入样例#1: 
4 4 5 8 8 
1 4 
2 3 
3 4 
4 7 
2 5 
5 6 
6 8 
7 8 
输出样例#1: 
22 



贪心一下, 我们最后的答案一定是两人同时经过一个节点, 然后一起走到终点(这个节点可能为根节点,代表中间不一起走)。
于是我们跑三遍spfa,算出来三个花费的最短路,然后按照上面的贪心思路算出答案,取min就行了。
貌似有复杂度更小的方法...直接bfs, 可以做到O(n),然后算花费直接乘b,e,p...
这样O(N)解决, 貌似比我的更优...不过都能AC就不管了...


 
#include <iostream>
#include <cstdio> 
#include <queue>
#include <cstring>
using namespace std;

int b, e, p, n, m;
int dis1[40005], dis2[40005], dis3[40005];
struct edge{
    int nxt, to;
}ed[1000005];
int head[40005], cnt;
inline void add(int x, int y)
{
    ed[++cnt] = (edge){head[x], y};
    head[x] = cnt;
}
bool ex[40005];

int main()
{
    scanf("%d%d%d%d%d", &b, &e, &p, &n, &m);
    for (int i = 1 ; i <= m ; i ++)
    {
        int x, y;
        scanf("%d%d", &x, &y);
        add(x, y), add(y, x);
    }
    
    queue <int> q;
    q.push(1);
    memset(dis1, 0x3f, sizeof dis1);
    dis1[1] = 0;
    ex[1] = 1;
    while(!q.empty())
    {
        int x = q.front();q.pop();ex[x] = 0;
        for (int i = head[x] ; i ; i = ed[i].nxt)
        {
            int to = ed[i].to;
            if (dis1[to] > dis1[x] + b)
            {
                dis1[to] = dis1[x] + b;
                if (!ex[to]) {ex[to] = 1;q.push(to);}
            }
        }
    }
    
    q.push(2);
    memset(dis2, 0x3f, sizeof dis2);
    memset(ex, 0, sizeof ex);
    dis2[2] = 0;
    ex[2] = 1;
    while(!q.empty())
    {
        int x = q.front();q.pop();ex[x] = 0;
        for (int i = head[x] ; i ; i = ed[i].nxt)
        {
            int to = ed[i].to;
            if (dis2[to] > dis2[x] + e)
            {
                dis2[to] = dis2[x] + e;
                if (!ex[to]) {ex[to] = 1;q.push(to);}
            }
        }
    }    
    
    q.push(n);
    memset(dis3, 0x3f, sizeof dis3);
    memset(ex, 0, sizeof ex);
    dis3[n] = 0;
    ex[n] = 1;
    while(!q.empty())
    {
        int x = q.front();q.pop();ex[x] = 0;
        for (int i = head[x] ; i ; i = ed[i].nxt)
        {
            int to = ed[i].to;
            if (dis3[to] > dis3[x] + p)
            {
                dis3[to] = dis3[x] + p;
                if (!ex[to]) {ex[to] = 1;q.push(to);}
            }
        }
    }    
    
    int ans = 1e9;
    for (int i = 1 ; i <= n ; i ++)
    {
        ans = min(ans, dis1[i] + dis2[i] + dis3[i]);
    }
    printf("%d\n", ans);
    return 0;
}
 
    

 


转载于:https://www.cnblogs.com/BriMon/p/9351121.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
### 内容概要 《计算机试卷1》是一份综合性的计算机基础和应用测试卷,涵盖了计算机硬件、软件、操作系统、网络、多媒体技术等多个领域的知识点。试卷包括单选题和操作应用两大类,单选题部分测试学生对计算机基础知识的掌握,操作应用部分则评估学生对计算机应用软件的实际操作能力。 ### 适用人群 本试卷适用于: - 计算机专业或信息技术相关专业的学生,用于课程学习或考试复习。 - 准备计算机等级考试或职业资格认证的人士,作为实战演练材料。 - 对计算机操作有兴趣的自学者,用于提升个人计算机应用技能。 - 计算机基础教育工作者,作为教学资源或出题参考。 ### 使用场景及目标 1. **学习评估**:作为学校或教育机构对学生计算机基础知识和应用技能的评估工具。 2. **自学测试**:供个人自学者检验自己对计算机知识的掌握程度和操作熟练度。 3. **职业发展**:帮助职场人士通过实际操作练习,提升计算机应用能力,增强工作竞争力。 4. **教学资源**:教师可以用于课堂教学,作为教学内容的补充或学生的课后练习。 5. **竞赛准备**:适合准备计算机相关竞赛的学生,作为强化训练和技能检测的材料。 试卷的目标是通过系统性的题目设计,帮助学生全面复习和巩固计算机基础知识,同时通过实际操作题目,提高学生解决实际问题的能力。通过本试卷的学习与练习,学生将能够更加深入地理解计算机的工作原理,掌握常用软件的使用方法,为未来的学术或职业生涯打下坚实的基础。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值