ZOJ 3203 Light Bulb(数学对勾函数)

Light Bulb

Time Limit: 1 Second      Memory Limit: 32768 KB

 

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers Hh and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input
3
2 1 0.5
2 0.5 3
4 3 4
Sample Output
1.000
0.750
4.000

 


Author: GUAN, Yao
Source: The 6th Zhejiang Provincial Collegiate Programming Contest

#include <iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int t;
double h,H,D;
int main()
{
    while(~scanf("%d",&t))
    {
     for(;t>0;t--)
     {
         scanf("%lf%lf%lf",&H,&h,&D);
         //最优解在[x0,x2]之间,如果能取到x1,则影子最长
         //影子长度在此区间内,符合倒钩函数l=H+D-x-D*(H-h)/x
         double x0=D*(H-h)/H;//在墙壁上的影子长度为0时,人与灯的距离
         double x1=sqrt(D*(H-h));
         double x2=D;//人不断向后移(也就是向墙壁移动),最远到墙壁,人与灯的距离
         double x;
         if (x0<=x1 && x1<=D) x=x1; //区间包含x1
         else if(x2<=x1) x=x2;//区间在x1的左边,即最大值小于x1
         else if(x0>=x1) x=x0;//区间在x1的右边,即最小值大于x1
         printf("%.3lf\n",H+D-x-D*(H-h)/x);
     }
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/stepping/p/6401148.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值