hdu4355 三分

F - 三分

Crawling in process... Crawling failed Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

In the Dark forest, there is a Fairy kingdom where all the spirits will go together and Celebrate the harvest every year. But there is one thing you may not know that they hate walking so much that they would prefer to stay at home if they need to walk a long way.According to our observation,a spirit weighing W will increase its unhappyness for S 3*W units if it walks a distance of S kilometers.
Now give you every spirit's weight and location,find the best place to celebrate the harvest which make the sum of unhappyness of every spirit the least.
 

Input

The first line of the input is the number T(T<=20), which is the number of cases followed. The first line of each case consists of one integer N(1<=N<=50000), indicating the number of spirits. Then comes N lines in the order that x [i]<=x [i+1] for all i(1<=i<N). The i-th line contains two real number : X i,W i, representing the location and the weight of the i-th spirit. ( |x i|<=10 6, 0<w i<15 )
 

Output

For each test case, please output a line which is "Case #X: Y", X means the number of the test case and Y means the minimum sum of unhappyness which is rounded to the nearest integer.
 

Sample Input

1 4 0.6 5 3.9 10 5.1 7 8.4 10
 

Sample Output

Case #1: 832
题目大意:类似于回归曲线拟合,寻找 最优解。
思路分析:很明显从区间左->区间右,unhappiness是先减。。。。后增,目测单峰函数,用三分姿势
注意精度不要太高,弱卡1e-8,1950ms险过orz.
代码:
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <cmath>
using namespace std;
const int maxn=50000+100;
#define eps 1e-8
const int inf=0xfffffff;
const double pi=acos(-1.0);
struct nod
{
    double x;
    double w;
};
nod s[maxn];
int n;
double len(double a)
{
    double sum=0;
    for(int i=0;i<n;i++)
    {
        double d=fabs(s[i].x-a); sum+=d*d*d*s[i].w;
    }
    return sum;
}
int kase=0;
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        double l=inf,r=-inf;
        for(int i=0;i<n;i++)
        { scanf("%lf%lf",&s[i].x,&s[i].w); l=min(l,s[i].x);
            r=max(r,s[i].x);
        }
        while(l+eps<=r)
        {
            double mid=(l+r)/2;
            double mmid=(mid+r)/2;
            double t1=len(mid),t2=len(mmid);
            if(t1<=t2) r=mmid;
            else l=mid;
        }
        printf("Case #%d: %.lf\n",++kase,len(l));
    }
    return 0;
}

转载于:https://www.cnblogs.com/xuejianye/p/5529134.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值