polygon

polygon
Time Limit: 1000 MSMemory Limit: 32768 K
Total Submit: 38(28 users)Total Accepted: 29(27 users)Rating: Special Judge: No
Description

We have a special polygon that all points have the same distance to original point.As you know

we can get N segments after linking the original point and the points on the polygon,

then we can also get N angles between each pair of the neighbor segments.

Now give you the data about the angle, please calculate the area of the polygon.

Input

There are multiple test cases.

The first line contains two integer N and D indicating the number of the points and their distance to original point. (3 <= N <= 10, 1 <= D <= 10)

The next lines contains N integers indicating the angles. The sum of the N numbers is always 360.

 

Output

For each test case

output one float numbe indicating the area of the polygon. The printed value should have 3 digits after the decimal point.

 

Sample Input

4 1

90 90 90 90

6 1

60 60 60 60 60 60

Sample Output

2.000

2.598

Hint
原点在多边形内部,各顶点与原点相连得到相邻两线段夹角小于180度
Author
陈禹@HRBUST

 题目大意: 给你一个多边形,多边形中间有一个点,多边形上的点距离这个原点都相等,已知这个距离和相邻两个点与这个原点组成的夹角

求面积

#include <math.h>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
using namespace std;
int N;
double d;
double PI=atan(1)*8;
int main()
{
    //cout<<PI<<endl;
    while(~scanf("%d%lf",&N,&d))
    {
        double ans;
        double sum=0;
        int i;
        for(i=0;i<N;i++)
        {
            scanf("%lf",&ans);
            ans=ans/360*PI;
            sum+=d*d*sin(ans)/2;
        //    cout<<sin(ans)<<endl;
        }
        printf("%.3lf\n",sum);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/beige1315402725/p/4921812.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值