hdu 5734 Acperience(2016多校第二场)

Acperience

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 484    Accepted Submission(s): 258
 
Problem Description
Deep neural networks (DNN) have shown significant improvements in several application domains including computer vision and speech recognition. In computer vision, a particular type of DNN, known as Convolutional Neural Networks (CNN), have demonstrated state-of-the-art results in object recognition and detection.

Convolutional neural networks show reliable results on object recognition and detection that are useful in real world applications. Concurrent to the recent progress in recognition, interesting advancements have been happening in virtual reality (VR by Oculus), augmented reality (AR by HoloLens), and smart wearable devices. Putting these two pieces together, we argue that it is the right time to equip smart portable devices with the power of state-of-the-art recognition systems. However, CNN-based recognition systems need large amounts of memory and computational power. While they perform well on expensive, GPU-based machines, they are often unsuitable for smaller devices like cell phones and embedded electronics.

In order to simplify the networks, Professor Zhang tries to introduce simple, efficient, and accurate approximations to CNNs by binarizing the weights. Professor Zhang needs your help.

More specifically, you are given a weighted vector  W=(w1,w2,...,wn). Professor Zhang would like to find a binary vector B=(b1,b2,...,bn) (bi{+1,1})and a scaling factor α0 in such a manner that WαB2 is minimum.

Note that  denotes the Euclidean norm (i.e. X=x21++x2n−−−−−−−−−−−√, where X=(x1,x2,...,xn)).
 

 

Input
There are multiple test cases. The first line of input contains an integer  T, indicating the number of test cases. For each test case:

The first line contains an integers n (1n100000) -- the length of the vector. The next line contains n integers: w1,w2,...,wn (10000wi10000).
 

 

Output
For each test case, output the minimum value of  WαB2 as an irreducible fraction "p/q" where pq are integers, q>0.
 

 

Sample Input
3
4
1 2 3 4
4
2 2 2 2
5
5 6 2 3 4
 

 

Sample Output
5/1
0/1
10/1
 
Author
zimpha
 
 
题意: 给定w1-wn的值,α>=0,B可以等于1或者-1,求这个的最小值。定义运算:
 

数学推论题,可以推出数学计算公式。

(w1-aB1)^2+(w2-aB2)^2+...(wn-aBn)^2

w1的取值范围是−10000wi10000,由于B1既可以取1也可以取-1,因此可以将所有的负数变为正数考虑。

因此:(|w1|-a)^2+(|w2|-a)^2+...(|wn|-a)^2(以后的w 全部为|w|,麻烦不想写)

又因为 要取最小值,显然 a=(w1+w2+...+wn)/n

展开式子 : w1^2+a^2-2aw1

       w2^2+a^2-2aw2

                   ......

                wn^2+a^2-2awn

得:(w1^2+w2^2+...+wn^2)+na^2-2a(w1+w2+...+wn)

将w1^2+w2^2+...+wn^2看作s1,w1+w2+...+wn看作s2,则:s1+na^2-2as2

且a=(w1+w2+...+wn)/n=s2/n   

得 : s1+n(s2/n)^2-2(s2/n)*s2=s1+s2^2/n-2(s2^2)/n=(ns1-s2^2)/n

 

附上代码:

 

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#define  ll long long
using namespace std;

ll _gcd(ll x,ll y)
{
    ll z;
    if(x<y) z=x,x=y,y=z;
    while(y)
    {
        z=x%y;
        x=y;
        y=z;
    }
    return x;
}

int xabs(int x)
{ 
    return x>0?x:-x;
}
int main()
{
    int T,i,j,n,m;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        ll aa,bb,t;
        ll s1=0,s2=0;
        for(i=0;i<n;i++)
        {
            scanf("%d",&m);
            m=xabs(m);
            s1+=m*m;
            s2+=m;
        }
        aa=n*s1-s2*s2;
        bb=n;
        t=_gcd(aa,bb);
        printf("%lld/%lld\n",aa/t,bb/t);
    }
    return 0;
}

 

 

 


转载于:https://www.cnblogs.com/pshw/p/5694520.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值