题目34:树查找

http://ac.jobdu.com/problem.php?cid=1040&pid=33

题目描述:

有一棵树,输出某一深度的所有节点,有则输出这些节点,无则输出EMPTY。该树是完全二叉树。

输入:

输入有多组数据。
每组输入一个n(1<=n<=1000),然后将树中的这n个节点依次输入,再输入一个d代表深度。

输出:

输出该树中第d层得所有节点,节点间用空格隔开,最后一个节点后没有空格。

样例输入:
4
1 2 3 4
2
样例输出:
2 3
// 题目34:树查找.cpp: 主项目文件。

#include "stdafx.h"
#include <iostream>
#include <math.h>
using namespace std;

const int N=1003;
int a[N];

int main()
{
    int n;
	while(cin>>n)
	{
		for(int i=0;i<n;i++)
			cin>>a[i];
		int depth;
		cin>>depth;
		int start=(int)pow(2.0,depth-1);
		bool flag=true;
		for(int i=0;i<start&&start+i-1<n;i++)
		{
			if(flag)
			{
				flag=false;
				cout<<a[start+i-1];
			}
			else
				cout<<" "<<a[start+i-1];
		}
		cout<<endl;
	}
    return 0;
}


转载于:https://www.cnblogs.com/cjweffort/archive/2013/03/05/3374908.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值